Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Torch™

New Member
Posts: 1
Registered: ‎06-08-2012
My Device: Blackberry 9860
My Carrier: T-mobile

email settings fault

I have three email addresses set up on my phone, (instantemail.t-mobile, ntlworld and gmail) which have worked for a few months without problem.  Today, went to change an email password in email set up, and the screen said checking for updates, initialising application, then displayed a license screen, which i accepted (why not?) and t then wiped all three accounts.  Support said I had accidentally create a new blackberry account (dont think i did).


They reset everything, but later in the day i tried to enter the email settings menu (clicking settings\email settings) and the same thing happened.  This time i tried to back out instead of accepting the prosumer agreement, but too late, all gone.


Called support again and he confirmed that the phone had wiped its imei and pincode from m yblackberry account.  Once he had reinstalled it all, it was fine.  Told me not to touch the icon again, but unfortunately the gmail account on the website access said i needed to activate contact synchronisation by opening email settings.  He told me to do it, and it instantly wiped off all three accounts. 


No idea whats going on, offered to swap the phone, but i cant until i return from a business trip at th end of the month.   I have recently updated the OS via desktop manager (it told me too, i was happy with the existing one!) but support said this wasnt the issue.  I think maybe the new OS has a bug? 


Anyone else experienced this or do you have a fix?   I dont need to desparately go into the settings but its a bit bad when you darent touch the icons in case they mess the phone up.


All thoughts appreciated (except derogatory ones of course!)

Hall of Famer II
Posts: 54,010
Registered: ‎11-28-2008
My Device: Z10/Z30/Q10 (, Playbook (
My Carrier: TMobile USA

Re: email settings fault

Hi and Welcome to the Community!


It may be that the on-device Email setup app has a problem...its happened. But, the latest KB on the matter applies only to OS6...I don't know if the recommended work arounds are valid for OS7 devices or not:

  • KB26055 BlackBerry smartphone is unable to access the Email Setup Application after auto-updating

As an alternative, you can avoid the on-device email setup app completely by using, from a PC/browser, your carriers BIS website:

Good luck!

Special through 31-Oct-2015 -- 10% Discount at ShopBlackBerry.com! Click here for details.

Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? click here and also here. Please click here for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button.