Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
New Developer
Posts: 10
Registered: ‎03-24-2009
My Device: Not Specified

App World problem - cannot download app in draft mode

Hello,

 

I just uploaded a new version of an application with InAppPurchase to the store. The app is still in draft mode.

When starting appworld for downloading the test app, it upgraded the App World to 3.0.0.73.

Now when I press alt + tst and I enter my bundle name (Product SKU name). I get the message that it could not connect to BlackBerry App World and I should ensure that my wifi is connected.

But the wifi is connected, I can even browse the apps in the store.

 

With previous app world version it worked as described in the docs, But now I cannot download my draft application for testing the InAppPurchase.

 

Can it be a problem with the RIM App world server or with the App World version 3.0.0.73?

Any ideas?

 

Thanks,

Sebastian

 

 

 

 

Highlighted
New Contributor
Posts: 4
Registered: ‎02-11-2011
My Device: Bold 9700
My Carrier: TMobile

Re: App World problem - cannot download app in draft mode

Having the exact same problem.
New Contributor
Posts: 8
Registered: ‎09-24-2011
My Device: BlackBerry Torch 9800
My Carrier: MTS

Re: App World problem - cannot download app in draft mode

We have the same problem. Can't download and can't check in-app purchase. 

Dear BlacKBerry Team, please help! 

BlackBerry Development Advisor
Posts: 310
Registered: ‎03-13-2009
My Device: BlackBerry Z30
My Carrier: RIM

Re: App World problem - cannot download app in draft mode

Hi guys,

 

Thanks for bringing this up.  We've identified this as a problem in the current version of App World 3.0, and are working on a fix for the next client Release. 

 

I apologize for the problems this is causing in your testing.

New Contributor
Posts: 8
Registered: ‎09-24-2011
My Device: BlackBerry Torch 9800
My Carrier: MTS

Re: App World problem - cannot download app in draft mode

Hi Ryan, thanks for your quick reply,

 

May be you can help me,

 

how can we test in-app purchase before we submit application to approve?

I don't want to release application If I can not get confirmation that this functionality works 

 

Thanks. 

New Developer
Posts: 10
Registered: ‎03-24-2009
My Device: Not Specified

Re: App World problem - cannot download app in draft mode

Any updates on this issue?

 

Just retried with Bundle name and Bundle ID, but none worked.

 

 

Developer
Posts: 658
Registered: ‎10-08-2009
My Device: Bold 9900
My Carrier: Telus

Re: App World problem - cannot download app in draft mode

It's already been two weeks. This is a more serious problem than you seem to think. The in app payment, for example, can only be tested via sandbox accounts.

 

Please take this problem more seriously. It's been two weeks already since you've "acknowledged" the issue.

----------------------------------------------------------
Twitter: @gyubok
Regular Contributor
Posts: 69
Registered: ‎04-05-2010
My Device: Storm
My Carrier: BSNL

Re: App World problem - cannot download app in draft mode

Today there was a Blackberry Webinar on In-App payment. I got to know that fix for this will be available from next App world release. That is excpected end of this month.
Developer
Posts: 16,741
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: App World problem - cannot download app in draft mode

Installed the new AppWorld version today, but alt+tst followed by the SKU does not work. Same issue as OP.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
New Developer
Posts: 10
Registered: ‎03-24-2009
My Device: Not Specified

Re: App World problem - cannot download app in draft mode

Just rechecked today. Stil the same issue - nothing happened.

Can someone from RIM give any statement.