Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
Visitor
Posts: 1
Registered: ‎09-22-2011
My Device: BOLD 9780
My Carrier: Orange UK

Appworld not installing on simulated 9780

Ive installed it according to the simulator but after a reboot it remains as appworld 2 any ideas ? 

Developer
Posts: 1,452
Registered: ‎11-06-2009
My Device: Torch 9810
My Carrier: WiFi

Re: Appworld not installing on simulated 9780

IMO simulators have some preloaded disk image with OS, core modules etc. I tried to update BBM for example and it didn't work - after restart the previous version came up.

 

If you want to see App World 3.0 on simulator, use simulator without preloaded App World like Storm 2 etc (or every simulator with OS 5.0), so you can download and install the latest version



"When you become a level 3 developer, you learn to communicate over the ether. I'm told that level 5 developers are ascend into a higher level of existence beyond the physical realm." gord888 @ crackberry
Developer
Posts: 64
Registered: ‎02-12-2011
My Device: 9300
My Carrier: Yoigo

Re: Appworld not installing on simulated 9780

I managed to install AppWorld 3.1 in a 9900 simulator that had a previous version installed.

First, I went to the simulator folder (C:\Program Files (x86)\Research In Motion\BlackBerry Smartphone Simulators 7.0.0\7.0.0.236 (9900)) and deleted all references to AppWorld there. There was an alx at the root and many .cod at the Java Folder.

Then I opened the 9900.xml file from the root folder and delete the appworld mention (so Eclipse didn't complain about it).

Finally I open the simulator and installed the new version.

Now everytime I run the simulator, version 3.1 is running Smiley Happy