Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
Contributor
yohanip
Posts: 23
Registered: ‎11-19-2012
My Carrier: Three

Failed uploading file bundle

Hi there! Merry Chridtmas for those of you celebrate :smileywink:

 

As the title suggest, i had filled all the forms before the file bundle uploading. It fails everytime i upload the bar file. It never shows what kind of error (My file size was 20mb)

 

Here is my exact step:

1. vendor Portal >> Manage Portal

2. click the "+" sign under the Releases

3. STEP 4 TAB : Give the bundle name, selecting platform QNX, select min os 2.1.0, select Playbook device support, select English (En), and then click on the pencil icon

4. Click the "Add" button, selecting my file (arround ~25MB)

5. I'm using chrome browser ver 23.0.xxxx, after chrome indicated i have uploaded the file (upload 100% progress) , it goes back to the popup window which show uploaded files.. the only problem is.. there is nothing in there.. no error message, nothing..

6. If i disregards, anything and then click on the "OK" button, it will redirect to some ip address.. and then connection is dead..

 

 

err..

Help??

 

Thanks.

 

Ps. Maybe it will help if i tell you that i have a very slow internet connection.. uploading ~25MB took arround 15 to 20 minutes

Please use plain text.
New Contributor
jkramarz
Posts: 7
Registered: ‎11-11-2012
My Carrier: Play

Re: Failed uploading file bundle

[ Edited ]

yohanip,

Have you tried using developer tools (CTRL+SHIFT+J) in Chrome to track your post request?

It could be a problem with your carrier provider. I've similar problem when I remain connected to remote SSH server - the connection is dropped after about 15 minutes.

What's your operating system?

Please use plain text.
Contributor
yohanip
Posts: 23
Registered: ‎11-19-2012
My Carrier: Three

Re: Failed uploading file bundle


jkramarz wrote:

yohanip,

Have you tried using developer tools (CTRL+SHIFT+J) in Chrome to track your post request?

It could be a problem with your carrier provider. I've similar problem when I remain connected to remote SSH server - the connection is dropped after about 15 minutes.

What's your operating system?


Hi Jkramarz, thank you,

i tried them with diffrent browser, chrome, firefox, and then ie, all returns the same after the file uploaded successfully (at least i think it was susccessfull because the upload dialog was gone..)

 

here is the post request when file uploading request..(i even use chrome add on to auto refresh other tab isvportal so that i should remain logged in..)

 

https://appworld.blackberry.com/isvportal/product/ajaxFileUpload.do?csrfToken=3U3R-KOFU-9O8Y-KQQU-####-O3AJ-####-####&csrfToken=3U3R-KOFU-9O8Y-KQQU-####-O3AJ-####-####

 

My operating system is Win 7

Please use plain text.
New Contributor
jkramarz
Posts: 7
Registered: ‎11-11-2012
My Carrier: Play

Re: Failed uploading file bundle

Have you tried uploading using batch import?
Can you successfully upload smaller app?
Please use plain text.
Contributor
yohanip
Posts: 23
Registered: ‎11-19-2012
My Carrier: Three

Re: Failed uploading file bundle


jkramarz wrote:
Have you tried uploading using batch import?
Can you successfully upload smaller app?

I Manage to upload other app which is 8mb in size, i haven't tried using batch import.. :smileyvery-happy: maybe i'll try that one..

 

Here is a log which captured as soon as the upload completed..


[06:26:06.157] [struts2_jquery] publish topic : setOpenVariable

[06:26:06.157] [struts2_jquery] publish topic : dlgSessionTimeOutOpen

[06:26:06.160] [struts2_jquery] publish topic : checkIfDialogClose

[06:26:06.240] GET https://appworld.blackberry.com/isvportal/product/extendsession.do?extendsession=Y&_=1356391566169 [HTTP/1.1 200 OK 829ms]

[06:26:06.688] [jquery.form] state = uninitialized

[06:26:28.527] [jquery.form] isXml=false

[06:26:28.528] [struts2_jquery] publish topic : ajaxFileUploadComplete2

[06:26:28.533] [struts2_jquery] publish topic : closeUploadFileDialog

[06:26:28.540] [struts2_jquery] publish topic : checkIfDialogClose

http://10.243.20.28/isvportal/product/refreshFileBundleDetailsForm.do

[06:26:28.732] [jquery.form] Server abort: TypeError: getDoc(...) is undefined (TypeError)

 

And there it was.. the blank form..

 

Thank you jkramarz.

Please use plain text.
Contributor
yohanip
Posts: 23
Registered: ‎11-19-2012
My Carrier: Three

Re: Failed uploading file bundle

[ Edited ]

Ok, i had it worked out.. umm.. iguess.. sort of.., although it was not a solution, but it does it..

for anyone out there having this problem.. :smileywink:

 

1. After you had your file uploaded

2. You have a blank uploaded files.. close it

3. Do a re-load of the main page (if it ask you to re-send submitted data, hit the ok button..)

4. You should have your uploaded file there.. 

 

:smileyhappy:

Please use plain text.