Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
Regular Contributor
ashish_developer
Posts: 96
Registered: ‎05-15-2013
My Device: blackberry z10
My Carrier: blackberry
Accepted Solution

How to compile app in 10.0.0 sdk

hi,

i have made an app for blackberry z 10 . I have complied the application in sdk version 10.1.0.1020.When i am adding the app to the blackberry world via vandor portal what min os i should use while adding the release for the app??

according to this document  :

http://developer.blackberry.com/devzone/blackberryworld/blackberry_world_vendor_portal_release_notes...

 

in Known Issue for this relaese heading..

what min os i should set??

 

i want to launch my app for all z 10 os version (10.0.0) So should i choose this 10.0.0 while i have complied it in 10.1.0.1020 sdk?? or i should install 10.0.0 sdk and then complie the app in it??

please help..

thanks in advance

 

Please use plain text.
BlackBerry Development Advisor (Retired)
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: How to compile app in 10.0.0 sdk


ashish_developer wrote:

hi,

i have made an app for blackberry z 10 . I have complied the application in sdk version 10.1.0.1020.When i am adding the app to the blackberry world via vandor portal what min os i should use while adding the release for the app??

according to this document  :

http://developer.blackberry.com/devzone/blackberryworld/blackberry_world_vendor_portal_release_notes...

 

in Known Issue for this relaese heading..

what min os i should set??

 

i want to launch my app for all z 10 os version (10.0.0) So should i choose this 10.0.0 while i have complied it in 10.1.0.1020 sdk?? or i should install 10.0.0 sdk and then complie the app in it??

please help..

thanks in advance

 


It really depends on your target market. Right now 67% of in market BlackBerry 10 devices are running 10.1, 33% are running some variant of 10.0.X but should upgrade in the near future. If you would like to target all current devices then you would need to install SDK 10.0.10 or lower, recompile then upload to the vendor portal.

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.
Developer
jtegen
Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: How to compile app in 10.0.0 sdk

Could'nt he compile for 10.0.x and call it version x.x.x.1 for his app and then upload it for min OS 10.0.0 and then compile it again for 10.1.x and call it version x.x.x.2 and upload it again with a min OS of 10.1, and then everyone would get the latest version with the latest SDK?
Please use plain text.
BlackBerry Development Advisor (Retired)
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: How to compile app in 10.0.0 sdk


jtegen wrote:
Could'nt he compile for 10.0.x and call it version x.x.x.1 for his app and then upload it for min OS 10.0.0 and then compile it again for 10.1.x and call it version x.x.x.2 and upload it again with a min OS of 10.1, and then everyone would get the latest version with the latest SDK?

Yep, that's another option, and a good one to take advantage of any new features the app may need only present in the 10.1 SDK.

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.