Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
New Contributor
sebykpathrose
Posts: 6
Registered: ‎07-08-2013
My Device: Torch 9810
Accepted Solution

Latest version of app not available to some devices

 

In BB App world, the latest version is showing approved. But, when we try to install in device, the app world in the device (9900) not showing the latest version. The app name is AACM and latest version is 3.1

 

Please help to resolve the issue.

BlackBerry Development Advisor
rhearty
Posts: 306
Registered: ‎03-13-2009
My Device: BlackBerry Z30

Re: Latest version of app not available to some devices

[ Edited ]

Hello sebypathrose,

 

The most likely reason you are not seeing the newest version is because you have configured only 2 language-specific bundles on your 3.1 Release:

 

Bundle1 - Supported Languages:  English (en)

Bundle2 - Supported Languages: Arabic (ar)

 

What they means is only devices with specific language codes of "en" and "ar" will see your new 3.1 verison (ie. devices running "en_us" or "en_gb" will not see version 3.1).  Your previous 3.0 Release had 1 Bundle set to "All Languages".

 

Recommendation is to either:

 

a) Create a new Release with 1 Bundle and configure it to "All Languages" (may require you have just 1 app that allows the user to select their preferred language at startup or in a Settings screen)

 

b) Create a new Release with 4 Bundles: English (en), English (en_us), English (en_gb), Arabic (ar)

New Contributor
sebykpathrose
Posts: 6
Registered: ‎07-08-2013
My Device: Torch 9810

Re: Latest version of app not available to some devices

 

Thank you very much for the good information.

 

Now, I released the fact.

 

Is there any method to alter the settings to change the language to the release 3.1 in App World without submitting  new release? Because, we already informed users that 3.1 is available for download.

 

Please advice.

 

 

Sincerely

 

 

BR

 

 

BlackBerry Development Advisor
rhearty
Posts: 306
Registered: ‎03-13-2009
My Device: BlackBerry Z30

Re: Latest version of app not available to some devices

[ Edited ]

Hi,

 

The only option we really have here is the following.  Please let me know how you'd like to proceed:

 

a) I move Release 3.1 back to Draft and the 2 extra English bundles can be added.  The same COD files can be used, they just need to be targetting English (en_us) and English (en_gb).

 

b) You submit a 3.1.1 Release with either 1 "All Languages" Bundle or 4 language-specific Bundles.  I recommend 1 "All Languages" Bundle to avoid any further, unforeseen language conflicts/discrepancies.

New Contributor
sebykpathrose
Posts: 6
Registered: ‎07-08-2013
My Device: Torch 9810

Re: Latest version of app not available to some devices

 

Thank you for the reply.

 

I tested with 9810 device just now.

 

The display Language is English(US) and input language also same.

 

But, I can see 3.1 in App World.

 

Few hours before, we tested (remote collegue) in 9900 device and it seems 3.1 in App world.

But, another device, same 9900 model (language English(UK), is not showing 3.1. Here they can see only 3.0.

 

We are planning for one more release (may be 3.2) in a week time with some additional features.
 But, we would like to resolve this issue to 3.1 without resubmitting a new release.

 

As per your last message, please confirm whether the issue will be resolved by doing step (a) only? means if you can move the 3.1 build to draft and I add two more buldles and after that move the 3.1 back from draft .

 

Please confirm.

 

Regards

 

 

New Contributor
sebykpathrose
Posts: 6
Registered: ‎07-08-2013
My Device: Torch 9810

Re: Latest version of app not available to some devices

 

Hi,

 

Any chance to re-upload the COD file again to the 3.1 release (if you could delete / move the existing 3.1)  and edit the settings?

 

Regards

 

 

 

BlackBerry Development Advisor
rhearty
Posts: 306
Registered: ‎03-13-2009
My Device: BlackBerry Z30

Re: Latest version of app not available to some devices

Hello,

 

I've moved Release 3.1 back to a Draft state.  You can make whatever changes are required (replace the COD files, add additional Bundles, etc.).

 

Once ready, you can re-submit the Release as per normal.

New Contributor
sebykpathrose
Posts: 6
Registered: ‎07-08-2013
My Device: Torch 9810

Re: Latest version of app not available to some devices

Thanks a lot.

I edited the existing bundles, to change the Language to ALL and Min OS to 5 & 6 and also renamed one bundle name to ...3.1.0.0.

Actually I was trying to delete one bundle but not permitted. So, change as above.

Hope this will resolve the issue.

Right ?

Regards
BlackBerry Development Advisor
rhearty
Posts: 306
Registered: ‎03-13-2009
My Device: BlackBerry Z30

Re: Latest version of app not available to some devices

Correct, you won't be able to remove a Bundle but the configuration you've changed them to should resolve the problem.

 

I've re-approved the Release.  It may take a few hours before we see if the changes have solved the problem of some users not seeing the newest version. 

New Contributor
sebykpathrose
Posts: 6
Registered: ‎07-08-2013
My Device: Torch 9810

Re: Latest version of app not available to some devices

 

Thank you so much.

 

Your support was very much valuable to us.

 

Regards