Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
Developer
Posts: 374
Registered: ‎02-12-2011
My Device: Bold 9780
My Carrier: Wind Mobile
Accepted Solution

Payment API 1.8

Says in documentation App World 3.1 or greater is required for Payment API to function.

 

Thats fine, but all the simulators I am finding are 2.X or 3.0.X.. I tried to upgrade the app world on the simulator, but after it requires a reboot, so I restart fledge and the old version is still there.

 

How am I supposed to test in app payment on the simulator if I cannot get the latest version of App World.

 

I tried (9900 sim, 9790, 9360, 9800)

 

I don't have a device to test on.

Developer
Posts: 374
Registered: ‎02-12-2011
My Device: Bold 9780
My Carrier: Wind Mobile

Re: Payment API 1.8

http://supportforums.blackberry.com/t5/BlackBerry-App-World-Development/Appworld-not-installing-on-s...

Fixed it by following their steps, delete the appworld files and reinstall.

For some reason it never ending tells me I need to reboot my device. Every time I reboot it keeps prompting me, and also prompts me in the middle of in app purchase testing. I assume this is due to App World problem with simulator.