Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
Contributor
RobC450
Posts: 30
Registered: ‎08-06-2012
My Device: Playbook & Z10
My Carrier: Rogers / Thunder Bay Tel

blackberry app world error “bar manifest file package version must be greater than …"

I've started getting a weird error message when trying to upload a playbook app update to BlackBerry world. I think this problem started after installing version 1.6.1 of the eclipse plug-in.

 

The app written using Eclipse 3.7.2 with latest ADT and updates.

The error message:

"The package version in your .bar manifest file for signals_playbook must be greater than the previous version, but lower than any the next release version added to the vendor portal. Your .bar manifest file package version must be greater than 3.0. Correct your .bar manifest file and try again to continue."

My AndroidManifest.xml contains:

<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="ca.rcp.mobile.cror.signals"
    android:versionCode="7"
    android:versionName="3.1" >


The Manifest file contained within the BAR shows this info:

    Archive-Manifest-Version: 1.1
    Archive-Created-By: Apk2Bar version 1.6.1
    
    Package-Author: xxxxxxxx
    Package-Author-Id: some hash xxxxxxxxx
    Package-Name: xxxxx.cror.signals
    Package-Id: some hash xxxxxxxxx
    Package-Version: 1.0.7.1
    Package-Version-Id: some hash xxxxxxxx
    Package-Type: application
    Package-Architecture: armle-v7
    Package-Author-Certificate-Hash: some hash xxxxx
    
    Application-Name: Railway Signals
    Application-Id: some hash xxxxxxxx
    Application-Version: 1.0.7.1
    Application-Version-Id: some hash xxxxxxxxxxx
    Application-Requires-System: Tablet OS/2.0.0.7109


I can see why BlackBerry world is complaining, it thinks the version number is 1.0.7.1.

How do I get it to show 3.1.0.0??

I tried editing the manifest file contained within the bar, saving it and resubmitting. But that didn't work (didn't think it would but was worth a try).

Does anyone know where is the 1.0.7.1 coming from?
Can I override it?

Thanks
Rob

Please use plain text.
New Contributor
sureshbabum
Posts: 6
Registered: 2 weeks ago
My Device: BlackBerry10
My Carrier: 9952992412

Re: blackberry app world error “bar manifest file package version must be greater than …"

Change your vesrion name in android manifest file to 3.1.0.0 and generate a new bar file and upload it.

Please use plain text.