Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
New Contributor
afriendlyperson
Posts: 9
Registered: ‎02-27-2011
My Device: Not Specified

"Please ensure that all filebundles have devices selected to support."

Couldn't find anything about this error message on google or with search so I guess that it must really be something basic. When I try to add a release build to my product i get this error message.

I first tried just uploading the bar as a filebundle, then as a zip (which resulted in quite the same thing).

Could someone tell me what I'm doing wrong?

Of course I made sure that the application runs without problems on the simulator (expect for the sound channel bug).

Please use plain text.
New Contributor
edenman1
Posts: 2
Registered: ‎03-10-2011
My Device: Not Specified

Re: "Please ensure that all filebundles have devices selected to support."

You figure this out?  Running into the same issue.  I assume it wants me to manually select devices that I support, but I'd really rather not do that (and just say that I support everything above a certain OS level).  Seems like a regression, since the UI for picking devices has all been redone.

Please use plain text.
New Contributor
afriendlyperson
Posts: 9
Registered: ‎02-27-2011
My Device: Not Specified

Re: "Please ensure that all filebundles have devices selected to support."

This was hilarious. My (quite neglected) browser just played a prank on me. Get some random mainstream browser, create the filebundle, specify device series, type, etc. and so on.

Please use plain text.
New Contributor
edenman1
Posts: 2
Registered: ‎03-10-2011
My Device: Not Specified

Re: "Please ensure that all filebundles have devices selected to support."

Yea, I guess I just don't want to even have to specify device series, because it means I'll have to go manually update all our apps when they release a new device series.  This used to be possible, but doesn't seem to be anymore.

 

FWIW, I tried this on a mac on both the latest Chrome and Firefox, no difference.

Please use plain text.
New Contributor
newhereinc
Posts: 9
Registered: ‎01-14-2012
My Device: blackberry bold 9700
My Carrier: optus (australia)

Re: "Please ensure that all filebundles have devices selected to support."

there is a "blue pencil" next to devices and a pop up window appears so you can select the devices, thats why the error comes up

Please use plain text.