Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
New Developer
jbeach42
Posts: 63
Registered: ‎10-27-2010
My Device: 9900 and PlayBook

Re: reports not working again

when you say 'it' is working, are you referring to the reports? Cuz that worked for me in weeks.

-----------------------------------------------------------------------------
Apps:Beats Brainwave Entrainment - Awesome Timer - StarSlide - Save Santa
@jamiebeach
Please use plain text.
Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: reports not working again

Jamie, no, I don't believe anyone has reports working. This is all about charts at this point, since we pretty much know the reports won't be functional again until the RIM folks get back, learn of the problem, investigate, think of a fix, try it out, submit that for internal review, pass it by legal, and then push it out to the servers. ;-) :-(

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook

Re: reports not working again

My download reports are working

Please use plain text.
Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: reports not working again

Debugging with BGmot here in the #playbook-dev IRC chat on Freenode....

He'd never run a report before, so we thought maybe that was it. I had one report in my list still. Tried deleting it, and a Download report worked. I tried a Purchase report and it failed. Deleted all my reports again and tried again after logging out/in: still failed. Tried a Downloads report and it worked. Tried another and it worked.

Looks like perhaps Download reports work, possibly after clearing pre-existing reports? But Purchase reports do not work...

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Please use plain text.
Developer
smiley
Posts: 1,472
Registered: ‎07-14-2008
My Device: Z10

Re: reports not working again

I can confirm that deleting appworld cookie the graph works but not the report.

 

This is the same problem we had last year where the report is all screwed up.   This could be the same problem with the cookies.  It's now the 11th day and no one at RIM really cares.  some one at appworld department should be on the hook or even get fired for this.  No wonder all devs are leaving. :Surrender:

Please use plain text.
Developer
dbigham
Posts: 524
Registered: ‎04-01-2009
My Device: Z10, PlayBook

Re: reports not working again

Yes, Download reports have been working all along, it's just the Purchase reports that are down.

Please use plain text.
Contributor
rnarayanan
Posts: 15
Registered: ‎12-28-2011
My Device: BB 9900

Re: reports not working again


That is correct. Downloads report have always been working. The problem is ONLY with 'purchase' report. Strange thing is it does not give any error message - but it does not show up on the download page either.

 

Also, I tried on Google Chrome which had no history or cookie for my appworld login - same problem - Purchase report does not work.

 

 

Please use plain text.
Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: reports not working again

Argh, sorry... thread's so long at this point I lost track. Sorry about that.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Please use plain text.
Developer
shawnblais
Posts: 439
Registered: ‎10-25-2010
My Device: Not Specified

Re: reports not working again

This definately has nothing to do with local settings, as Distimo (an aggregation service) has been unable to pull a purchase report from AppWorld since Dec 18.

Please use plain text.
Regular Contributor
PlayDev
Posts: 82
Registered: ‎05-23-2011
My Device: Playbook

Re: reports not working again

re: Graphs - What I don't get is, they will literally be working one hour and not the next. You never know when they are going to be working. Very strange.

 

"as Distimo (an aggregation service) has been unable to pull a purchase report from AppWorld since Dec 18."

 

Yah I know. That sucks, I was getting some very useful stats from there.

Please use plain text.