Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry World

Reply
New Member
bamagrad
Posts: 1
Registered: ‎04-27-2012
My Device: Torch 9800

Re: App World not working after upgrade

I have the Torch 9800 and have tried everything you have...no luck. I'm marginally glad to know as well that I'm not alone in my struggle. You're the first person I've noticed who's mentioned the holding down the BB key and it showing as open but not really open.
Contributor
eywong
Posts: 35
Registered: ‎03-12-2009
My Device: Z10 STL 100-3

Re: App World not working after upgrade

This issue (autostart after device reboot; no App World icon) started for me with a December 2011 beta release of the App World app. Reading the discussions on the beta boards, I get the impression that the software developers are unable to identify the exact cause of the problem.

Contributor
lainchir
Posts: 33
Registered: ‎02-17-2011
My Device: Not Specified

Re: App World not working after upgrade

It would be nice to roll back at least, or be given the option of installing an earlier version from the web. At the moment... I'm stuck with no option.
New Member
mkereliuk
Posts: 1
Registered: ‎04-29-2012
My Device: Bold 9650

Re: App World not working after upgrade

I am having the same problem on my Bold 9650 after updating.  I've noticed that app world appears to be running at all times in the background but if I try to switch to it using switch application, it won't open.  The phone just freezes for a couple seconds and nothing happens.  Doing a battery pull doesn't seem to fix the issue, but I have found that if you go into settings > device > application management (or whatever the equivalent is on other models), delete app world, reboot the phone, and re-install app world from the website, app world will work temporarily.  I've done this twice already, but after several hours after the fresh install it gets stuck open in the background again, and will not load.

 

I think this issue is a bug with the 3.1.2.32 update; hopefully a new release will address this soon.

New Contributor
pjl_1
Posts: 9
Registered: ‎04-26-2012
My Device: Torch

Re: App World not working after upgrade

I too have deleted App World and reinstalled but is does not work temporarily after re-install.

 

After re-install clicking the App World icon results in no action!

New Contributor
pjl_1
Posts: 9
Registered: ‎04-26-2012
My Device: Torch

Re: App World not working after upgrade

Now working!

 

I checked the last appworld log file (using Blackberry Desktop Software) which appeared to point at a failure to cleanup previous app install data. So I deleted those files. I also deleted my most recently installed apps.

 

Appworld then installed ok direct from the browser on my 9800.

 

No sign of the APPWORLD in the Service Book folder though .... was that a red herring??

 

A bit drastic / risky perhaps but it worked for me. Good luck.

New Contributor
Jiggiwatt
Posts: 8
Registered: ‎04-26-2012
My Device: Torch 9800

Re: App World not working after upgrade

How did you find all this using the Desktop software ? Maybe I have an older version, but I was just able to generate a log file dump/support package and the logs in there aren't telling me a whole lot.

New Contributor
pjl_1
Posts: 9
Registered: ‎04-26-2012
My Device: Torch

Re: App World not working after upgrade

I have Desktop Software v 6.1.0.35.

 

On the left Menu bar click 'Files'. browse to device/home/user/appworld/logs.

 

I looked for the latest file

 

 

 

New Contributor
Jiggiwatt
Posts: 8
Registered: ‎04-26-2012
My Device: Torch 9800

Re: App World not working after upgrade

So here's a play by play:

 

1) Connect your blackberry to your PC and launch the Desktop Software

2) Click on 'files' on the left and click 'Get Started' if this is the first time you've launched the Files tool

3) Browse to Store/home/user/appworld/img and delete the 'screenshots' directory

4) On your phone, go to Options -> Device ->Application Management -> Blackberry App World and choose 'Delete'

5) Reinstall app world from the web download

 

For posterity, here's the error:

 

[2012-04-26 10:05:57.479][ERROR]Failed on CleanOldBitmaps task on deleting file:///store/home/user/appworld/img/screenshots/
 Exception Class: class net.rim.device.api.io.file.FileIOException
 Exception Detail: Directory not empty
 StackTrace: Traceback:
No detail message
net_rim_bb_appworld_lib-5(4F8DADC4)
 CleanOldBitmaps
 <private>
 0x3C13
net_rim_bb_appworld_lib-5(4F8DADC4)
 CleanOldBitmaps
 run
 0x3B2F
net_rim_bb_appworld_lib-1(4F8DADC4)
 Scheduler$TaskRunner
 run
 0x79AC
net_rim_bb_appworld_lib-1(4F8DADC4)
 Scheduler
 postEvent
 0x74A6
net_rim_bb_appworld_lib-1(4F8DADC4)
 ContentStore
 systemStartup
 0x5526
net_rim_bb_appworld_lib-1(4F8DADC4)
 ContentStore
 startAppWorld
 0x4F41
net_rim_bb_appworld(4F8DADD6)
 BlackBerryAppWorldMain
 main
 0x71
~

 

New Contributor
pjl_1
Posts: 9
Registered: ‎04-26-2012
My Device: Torch

Re: App World not working after upgrade

Exactly!

 

Any ideas about the cause of the problem?

 

Did I need to delete the last installed applications or could I have solved the problem just by deleting this screenshots folder?