Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry World

Reply
New Member
bb_kevin
Posts: 1
Registered: ‎04-21-2012
My Device: Playbook
My Carrier: Telecom NZ

Problem with App World 4.0.55

I have just upgraded App World to version 4.0.55, and now it is not working...

 

I can see the icon, but selecting it doesn't appear to do anything.  Holding the BB button shows the App World icon (as an application that is already running), and this is the case even immediately after a reboot.  Selecting the running app just returns me to the home screen.

 

I have completely uninstalled / rebooted / reinstalled twice now, with the same result.

 

Any suggestions on how I might resolve this? 

Please use plain text.
New Contributor
keithf
Posts: 2
Registered: ‎01-08-2010
My Device: 8830
My Carrier: Bell Mobility

Re: Problem with App World 4.0.55

I am having the same problem.

I uninstalled 4.0.0.55 and went back to 3.1.1.21 and that version works ok.

Then upgraded to 4.0.55 again and it stopped working.

Now back at 3.1.1.21 again!

Please use plain text.
New Contributor
tingoat54
Posts: 2
Registered: ‎10-27-2012
My Device: 8530 curve
My Carrier: boostmobile

Re: Problem with App World 4.0.55

How did u uninstall app world ?
Please use plain text.
Trusted Contributor
BB4matt
Posts: 135
Registered: ‎07-25-2011
My Device: Z30, Torch 9800, Playbook
My Carrier: Telus

Re: Problem with App World 4.0.55

This is a suggestion for bb_kevin to try.

 

Action 1:
Please, start DTM 7.1, connect your phone, wait for the ‘sync all’ message, click on’ Applications’, wait for the ‘apps loading’ to stop, and check if you see a ‘red star’ on the top line and maybe at the bottom a message which says: ‘OSx.0.0…………Update’.
Also verify (scroll up/dn) in the list that AW 4.0.0.55 is installed (important).

 

Action 2:
If yes, go back to the hone screen of DYM 7.1 and make a full back up of your phone. Disconnect your phone and try 2 more reboots (either pull the battery for a few seconds or press ‘alt key, right shift key, and del key for 3 sec. all simultaneously if you have a keyboard).

 

Action 3:
Is the AW icon now working? If not check for the ‘red star’ again. If it still there you have to make a decision. You can go back to your present or default AW version and wait for a better version to come along or clean/update your current software to get rid off this icon issue via Action 4.

 

Action 4:
If you see on the bottom of the ‘Applications’ window still the ‘Update’ message click the ‘Apply’ button beside it. What will happen? This procedure stores your phone’s setting and PIM and email data and all your apps, then it erases all data, then it reinstalls your current OS software, and then reloads all the above stored data. One has to wait about 30 minutes till one get the ‘update complete’ message and then spend about another 10 minutes or so to follow all the prompts and reboots to get the phone back onto the network. Most of your third party apps will be back; other ones you need to reinstall later.

 

Action 5:
If you decided to ‘update’ your current software, disconnect your phone after you got the ‘update complete’ message and follow the prompts. Since this method reinstalls your current OS it will take about 10 minutes before you get an email from your phone company saying: Your handheld has been registered with the wireless network.

Wait for this message, because if you start your AW icon to early you will not be able to update your BB ID. I you did you will see a message like: Sorry, the software update server is unavailable. Please, try again. (RIM means, after you are back on your carriers network). Also, make sure your phone's radio is turned on after disconnecting from the PC.

 

Summary:
The above actions worked for my Torch 9800 running currently bundle 3049 and app platform version 6.6.0.246. I also experienced other issues in trying to install AW v.3.1.x.x and v. 4.0.0.x like:
missing AW icon to launch the app
Uncaught exception java.lang.Error
App World requires the latest version of BlackBerry ID.
Sorry, the software update server is unavailable. Please, try again
BlackBerry Identity installation failed. Please try again later. (80002)

 

If you don’t see a ‘red star’ on the first line of your apps list but are stuck on one of the above listed AW v.55 issues let me know in a response to this thread and I will suggest another way of doing an update avoiding the 'wipe way' of reinstalling the current OS.

 

Tip:
I deleted my PayPal app before I did the ‘Update’. I reinstalled the PayPal app after v.55 was running and had no issues with this app so far.

I hope this is not too much writing but these issues and errors are in RIM’s court for quite some time and

this method worked best for my phone. Maybe, for yours too. Good luck.

Please use plain text.
Trusted Contributor
BB4matt
Posts: 135
Registered: ‎07-25-2011
My Device: Z30, Torch 9800, Playbook
My Carrier: Telus

Re: Problem with App World 4.0.55

Some more feedback for bb_kevin and tingoat54

 

I just discovered another solution by JSanders. Go here:

 

http://supportforums.blackberry.com/t5/BlackBerry-App-World-General/Useless-App-World-ugrade/m-p/195...

 

and try this first. This is a much faster solution if it works. I will try this one too the next time my icon freezes because these current AW versions are still buggy. If everything is going good for a week, the icon might freeze up again and this would be a quick fix.

 

Give us some feedback what worked for you which will be feedback for many others.

Please use plain text.