Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry World

Reply
New Contributor
Posts: 3
Registered: ‎05-16-2010
My Device: Bold 9700

Receiving deleted emails over and over

Hi!  I upgraded up to the most recent firmware (v5.0.0.405), and ever since I have had very annoying email issues.  I have two email accounts set up on my Bold 9700 on AT&T, a normal POP3 account which works fine, and my GMail account. 

 

Before upgrading firmware, when I read an email from my Gmail account on the handset it would mark it as read on the server, and when I deleted an email from my Gmail on the handset it would archive the message in GMail, which I liked.  Now, not only does reading a message on the handset have no effect on the server, but even more bizarre, when I delete messages they are resent to me in bulk hours later, over and over.  Put another way, about three times a day I will receive another copy of every email I have received and deleted since initializing the account.

 

This seems very strange to me, so I have wiped my phone twice, deleted my email accounts, and tried to start from scratch, but I see the same behavior.  Since my other POP3 account is working fine, could it be something with the way that BIS sets up GMail accounts?

 

Of course using the Gmail App is another option, but I like having a working unified inbox, like I used to have on this same device.

Elite I
Posts: 6,343
Registered: ‎08-19-2008
My Device: 9800 - OS 6.0.0.246

Re: Receiving deleted emails over and over

Is your Gmail account setup via POP or IMAP?

_______________________________________________________________________________________________________________
If someone has been helpful please consider giving them kudos by clicking the star to the left of their post.
Remember to resolve your thread by clicking Accepted Solution.
New Contributor
Posts: 3
Registered: ‎05-16-2010
My Device: Bold 9700

Re: Receiving deleted emails over and over

Is it setup for POP or IMAP on the device?  I'm not totally sure.  My Gmail settings at Gmail.com show that I have both POP and IMAP enabled.

 

When I setup the email account on my blackberry it gave me several options for what kind of email account (Gmail, Yahoo, AOL, other, etc), and of course I chose Gmail.  Not sure what kind of configuration the default blackberry gmail account set me up with.

Elite I
Posts: 6,343
Registered: ‎08-19-2008
My Device: 9800 - OS 6.0.0.246

Re: Receiving deleted emails over and over

OK. Try this:

 

 

  • Delete the Gmail account from the BlackBerry
  • Go into the settings on gmail.com and disable POP and only enable IMAP
  • Wait 5 minutes and resetup the account on the BlackBerry.
See if the problem only happens when IMAP is enabled

 

_______________________________________________________________________________________________________________
If someone has been helpful please consider giving them kudos by clicking the star to the left of their post.
Remember to resolve your thread by clicking Accepted Solution.
New Contributor
Posts: 4
Registered: ‎05-16-2010
My Device: Curve 8330

Re: Receiving deleted emails over and over

Forgive me for cross-posting if it is against the etiquitte here, but I'm having the exact same problem and was attempting to fix it in another thread:

 

http://supportforums.blackberry.com/t5/BlackBerry-Internet-Service/GMail-2-way-Sync/td-p/473531

 

I'm still stumped also, and deleting and recreating the Gmail account does not seem to be the answer.  Right now, I think it has something to do with the IMAP folders / label integration and how archived messages are treated, but for the life of me I can't figure this out.

Matt

New Contributor
Posts: 3
Registered: ‎05-16-2010
My Device: Bold 9700

Re: Receiving deleted emails over and over

I followed your instructions, but weirdly, when I set up the Gmail account on the blackberry it re-enables POP on Gmail!  I don't understand how, but I've done this 3 times, and it's re-enabled it every time.