If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry World

Reply
Visitor
bbuser32
Posts: 1
Registered: ‎04-01-2009
My Device: Not Specified

error starting net_rim_bb_appworld

I have a blackberry pearl and installed appworld but when I attempt to run it I get the following error message: Error starting net_rim_bb_appworld: Symbol 'ContentHandlerRegistrationHelper.moduleUpgraded not found.

How do I fix that? I've already tried reinstalling but get the same error.

Thanks
Please use plain text.
New Contributor
crovax33
Posts: 2
Registered: ‎04-01-2009
My Device: Not Specified

Re: error starting net_rim_bb_appworld

I'm getting the same error on my pearl, and deleting the app and reinstalling didn't work.
Please use plain text.
New Contributor
crovax33
Posts: 2
Registered: ‎04-01-2009
My Device: Not Specified

Re: error starting net_rim_bb_appworld

Tried reinstalling then hard resetting (turned BB off, removed battery for ~6 seconds, turn back on), still getting the same thing.  Giving up until a fix is issued.
Please use plain text.
New Member
schwartzy98
Posts: 2
Registered: ‎04-01-2009
My Device: Not Specified

Re: error starting net_rim_bb_appworld

Another Pearl user here getting same message...
Please use plain text.
New Contributor
rturro
Posts: 3
Registered: ‎04-01-2009
My Device: Not Specified

Re: error starting net_rim_bb_appworld

Same deal.  Tried the hard reboot, didn't work.  RIM, let us know when you fix this.
Please use plain text.
New Contributor
silver
Posts: 2
Registered: ‎04-01-2009
My Device: Not Specified

Re: error starting net_rim_bb_appworld

I get "Error strting net_rim_bb_appworld:Module 'net_rim_bb_appworld-6 not found".  Reinstalled appworld 3 times, did cold reset twice by removing the battery. Even reinstalled Desktop 4.7.  No luck.  Listening, RIM?  
Please use plain text.
New Contributor
rturro
Posts: 3
Registered: ‎04-01-2009
My Device: Not Specified

Re: error starting net_rim_bb_appworld

I finally got it to work, but I had to go on the blackberry website and upgrade the operating software to version 4.5.  After that, no problem.  hope this helps.
Please use plain text.
New Contributor
silver
Posts: 2
Registered: ‎04-01-2009
My Device: Not Specified

Re: error starting net_rim_bb_appworld

What version of the Blackberry do you have Perl, Curve, etc. , in case that makes a difference.  Also, I am at OS version 4.7, does anybody else have the experience of it working on 4.5 but not on 4.7?  I can always downgrade, I think.  Thanks.
Please use plain text.
New Contributor
bettadaze
Posts: 2
Registered: ‎04-01-2009
My Device: Pearl 8130 v4.3.0.60

Re: error starting net_rim_bb_appworld

so far so good, after upgrading firmware to 4.5.  it didnt work right after i did the update, deleted app world, then reinstalled via desktop with  v4.5 and everything seems to work now.
Please use plain text.
New Member
msplue
Posts: 1
Registered: ‎08-02-2010
My Device: Pearl8130
My Carrier: Bell

Re: error starting net_rim_bb_appworld

I have the same problem.  Did you find out how to fix this yet it is very frustrating.  Thanks

Please use plain text.