Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Member
Posts: 1
Registered: ‎03-11-2013
My Device: blackberry z10
My Carrier: 0714271135

Blackberry Z10

Blackberry Support Team

 

I am currently experiencing issues with my new Blackberry Z10. Let me give you a bit of background, I bought this phone on Friday 8th March 2013 and I have been using. I haven’t installed any applications yet. Following are my issues.

 

  • My phone is heating up when I am using it as if it’s plugged in to the charger.
  • The battery of the phone discharges very quickly even when am not using the phone, it takes about 6 hours max.
  • My data bundles don’t last and the only thing I did was to enable my email accounts and social network accounts. (I haven’t downloaded any app but 100MB lasts me only 2 days)

There are no applications that are running at the background because every time am done using the app I close it. I have disable all other connection features such as Bluetooth, NFC, Wi-Fi, Hot-Spot, and VPN. I even decreased the display brightness thinking its consuming battery.

 

Today I connected my phone to Wi-Fi at my work place and my phone was working 100%. The battery lasted me the whole day. I have experienced any issues during office hours. Now am back at my place using Data Service (HSPDA) its acting funny again.

 

Please help, I really like and enjoying this new handset and I would wish to see it working like my previous Curve 8520 and Torch 9800.

 

Please please please help me with advises or solutions.

 

Thanking you in advanced.

Contributor
Posts: 35
Registered: ‎02-06-2013
My Device: Z10
My Carrier: Telus

Re: Blackberry Z10


mduzee wrote:

Blackberry Support Team

 

I am currently experiencing issues with my new Blackberry Z10. Let me give you a bit of background, I bought this phone on Friday 8th March 2013 and I have been using. I haven’t installed any applications yet. Following are my issues.

 

  • My phone is heating up when I am using it as if it’s plugged in to the charger.
  • The battery of the phone discharges very quickly even when am not using the phone, it takes about 6 hours max.
  • My data bundles don’t last and the only thing I did was to enable my email accounts and social network accounts. (I haven’t downloaded any app but 100MB lasts me only 2 days)

There are no applications that are running at the background because every time am done using the app I close it. I have disable all other connection features such as Bluetooth, NFC, Wi-Fi, Hot-Spot, and VPN. I even decreased the display brightness thinking its consuming battery.

 

Today I connected my phone to Wi-Fi at my work place and my phone was working 100%. The battery lasted me the whole day. I have experienced any issues during office hours. Now am back at my place using Data Service (HSPDA) its acting funny again.

 

Please help, I really like and enjoying this new handset and I would wish to see it working like my previous Curve 8520 and Torch 9800.

 

Please please please help me with advises or solutions.

 

Thanking you in advanced.


Have a look here for battery tips.  

http://helpblog.blackberry.com/2013/03/blackberry-z10-battery-tips/

 

My battery sucked when I first got it.  Once I did the 10.0.10.85 software update - it was great.

I turned off LTE and I turned of NFC and I only turn on bluetooth when I am using my headset.  These all helped me with battery life.

 

I went through the data-shock when I connected my email accounts - it downloads everything for the past 30 days (including attachments).  No way around this - compression is gone for good.  Downloading only headers is gone for now, but hopefully it will be restored - I hope so.

 

I try to make sure that I am on wifi if I am downloading large attachments, but that isn't always practical.

 

 

Forums Advisor III
Posts: 1,036
Registered: ‎02-07-2013
My Device: Z10
My Carrier: Rogers

Re: Blackberry Z10

Hi there,

This is not an 'official' support area for BlackBerry, it is a user to user community forum.

It sounds like you may be experiencing this issue:

http://supportforums.blackberry.com/t5/BlackBerry-Z10/Z10-Exchange-2003-300-MB-Data-usage-in-7-hours...

For this issue I would be seeking official support by calling my carrier and asking for the carrier's Blackberry support team, if they cannot help you the should escalate you to tier 2 blackberry support (this is at blackberry) they are obliged to escalate you if they cannot resolve your issue, so make sure they do and ask for a ticket number.

If it is a device or network issue, ask your carrier for a refund on the data.. it won't hurt to at least ask for it :smileyhappy:

-: DrewRead :-
Can't find an app on Blackberry World yet? Tweet the developer and ask when they will #GetWithBB10 !!
"Like it" if you like it. :smileyhappy: