Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
liamomurchu
Posts: 2
Registered: ‎04-24-2013
My Device: z10

Connectivity problems between wi-fi and 3G

Hi my name is Liam and I have recently purchased a BB Z10.

The Z10 runs BB 10 OS version 10.0.10.90, from which my phone tells me is the latest OS.

 

I having issues with connectivity i.e. between 3G data and wireless connections.

 

I have a wireless network at home and a wireless network at work; when I am not at either of these places I use the 3G connection. I leave the phone on with both wireless and 3G connectivity with the view that when I am home I connect to my home wi-fi network, when in work I connect to my work wi-fi network and when anywhere in-between as aforementioned.

I use exchange server as my work email; gmail as my personal mail and then browse normal web sites etc.

 

When I am at home; I connect to my home wi-fi automatically without any problems and can:

.View exchange work email

.View gmail personal email

.View web pages

 

When I am leave home; I obviously lose to my wi-fi  (as expected) and connect automatically to 3G from which:

.I cannot view exchange work email

.I cannot view gmail personal email

.I cannot view web pages

 

When I get to work; I lose my 3G connection (as expected) and connect to my work wi-fi automatically without any problems and can:

.I cannot view exchange work email

.View gmail personal email

.View web pages

 

As a test (at work), I disable my wi-fi. The phone now seems to disconnect from the Cell network as there is a phone handset icon in the top right hand corner and it has a ‘red’ exclamation mark next to it. When the screen lock appears it states ‘Emergency calls only’. The Network Connections show Mobile Network and EE (My cell provider).

(Still at work) If I restart the phone all works ok (on 3G)

.View exchange work email

.View gmail personal email

.View web pages

Switch back to wi-fi at work:

.I cannot view exchange work email (recent mail) BUT can send out work exchange mail

.I view gmail personal email

.I can view web pages

 

Reboot again and:

.View exchange work email

.I view gmail personal email

.I can view web pages

 

So this is pretty flakey – I am missing calls, missing emails….

I just hope it is a bug(s) and will be fixed soon as then I know that it will be fixed (and is not sporadic) and I have a normal smartphone that I can work it.

 

I look forward to replies / help!

 

Many thanks,

 

Liam.

 

 

 

Please use plain text.
BlackBerry Technical Advisor (Retired)
hatchback
Posts: 2,283
Registered: ‎09-09-2010
My Device: BlackBerry Z10 Smartphone

Re: Connectivity problems between wi-fi and 3G

Hey Liam,

Welcome to the BlackBerry® Support Community Forums.

 

To better diagnosis the cause of this issue we would suggest contacting your wireless service provider and request they contact BlackBerry technical support on your behalf for further investigation into this and to gather logs. 

 

Let me know if you have any other questions.
Thank you.

-HB

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

Please use plain text.
New Contributor
liamomurchu
Posts: 2
Registered: ‎04-24-2013
My Device: z10

Re: Connectivity problems between wi-fi and 3G

Hi Hatchback,

 

I guess I do not understand your respose or you have not understood my issue.... :smileyhappy:.

 

I am *not* connecting to a wireless provider network at home or at work.

I simply connect to my home broadband connection by means of a small wireless router and at work I connect to a Cisco access point which is connected to our LAN.

 

The issue seems to be with the blackberry Z10; when it has both wireless on and also 3G cell on; when you roam between your saved wireless connections, the switchover from wireless to 3G or from 3G to wireless does not seem to work properly unless you reboot the phone.

 

Note: my other phone ( a Nexus 4) and my wife's phone can connect to our home wireless router and then once we leave the house it switches automatically to the 3G cell.

 

I hope you now understand the issue? Or is this how it is supposed to work. 

 

Many thanks,

 

Liam.

Please use plain text.
Contributor
printe
Posts: 18
Registered: ‎04-09-2013
My Device: Z10 - User

Re: Connectivity problems between wi-fi and 3G

Hello Liam,

 

I've got the same on my Z10. I've contacted my provider (vodafone.de) and he told me, that he has trouble with his infrastrukture.

I am not sure if this is a Z10 Problem, I did not  have this in the Nederlands where all worked properly. One difference maybe the point, rebooting does not help in my case. This made me calling my carrier. My release is 10.0.10.99 - as I know, the carrier is responsible for the clearance of releases.

He also told me to switch of LTE, it may cause trouble if there is no LTE signal in your area.

 

MfG

Martin

Please use plain text.