Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
RandomBBUser1979
Posts: 4
Registered: ‎01-29-2014
My Device: Blackberry Z10
My Carrier: T-Mobile
Accepted Solution

Contact list problems after update to OS 10.2.1.537

Hi all,

 

I have run into issues with my address book since I updated my BB Z10 to the new OS 10.2.1.537.

 

My contacts are all synced with my Gmail contacts, and the syncing still works fine. However, they are displayed in the adress book on my Blackberry in a weird and random way. Some contacts are displayed perfectly fine as e.g. "Ms Jane Doe". In others, however, the institution at which the people work is displayed as part of the name, e.g. "Ms Doe Some Institute". In one case the display name of the contact was even changed to a date-time-coding (the time I last contacted that person?).

 

I checked the entries via "Edit" and they seem to be OK, first and middle names, surname, title, institutions and alike are all stored in their respective fields. They are only displayed wrongly in the contact list. Moreover, some contacts are displayed wrongly and some are not, and I did not find any one particular thing that any of the two groups has in common and that could trigger the error: In both groups I find entries with many (e.g. websites, Skype names, several phone numbers) or few (only one number or e-mail adress) entry-fields, as well as entries which have links to LinkedIn accounts etc., and so forth. So this problem occurs randomly?

 

I also figured out that "editing" a contact by just going to "Edit" and then saving without making any actual changes fixes the display issue. However, I would not want to manually go through that procedure for 200+ contacts. Also, since the problem seemingly occurs randomly, I have no idea whether it will happen again with new contacts in the future or even re-occur in already fixed contacts when I edit them in Gmail, upon the normal regular syncing, or after restarting the phone.

 

Does somebody else have these problems as well? And does somebody have an idea what might be the problem and even better how to fix it?

 

Thanks a lot.

Please use plain text.
Guru I
John_Clark
Posts: 15,122
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Contact list problems after update to OS 10.2.1.537

I would remove the contact sync (or the entire GMail account) under Settings >Accounts and then add it back.
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
Guru I
John_Clark
Posts: 15,122
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Contact list problems after update to OS 10.2.1.537

...Oh, and are you on Tmobile US? Did you get the update notification on your device?
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
New Contributor
RandomBBUser1979
Posts: 4
Registered: ‎01-29-2014
My Device: Blackberry Z10
My Carrier: T-Mobile

Re: Contact list problems after update to OS 10.2.1.537

No, that's T-mobile Germany. Do you think the provider has something to do with that. I will however try to cancel and reconnect Gmail contacts syncing and report whether or not it worked.

Please use plain text.
Guru I
John_Clark
Posts: 15,122
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Contact list problems after update to OS 10.2.1.537

No, I was just wondering since I have a second device on TMobile US and haven't gotten the update. I loaded this OS almost a month ago when it leaked on the Internet.
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
New Contributor
RandomBBUser1979
Posts: 4
Registered: ‎01-29-2014
My Device: Blackberry Z10
My Carrier: T-Mobile

Re: Contact list problems after update to OS 10.2.1.537

OK, deleting and reconnecting to Gmail worked fine. Thanks a lot.

Please use plain text.
Guru I
John_Clark
Posts: 15,122
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Contact list problems after update to OS 10.2.1.537

Glad to hear. Please mark the post that was the solution. That helps others searching the forums with similar issues.
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
Guru I
John_Clark
Posts: 15,122
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1052; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Contact list problems after update to OS 10.2.1.537

Nevermind
..i see you did already. Glad you're fixed uo!
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.