Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
jnak
Posts: 14
Registered: ‎09-02-2011
My Device: Blackberry Playbook

Data connection drops

[ Edited ]

I'm on Rogers.  I have an issue where my Z10 will be connected to both the mobile network and wifi, and I will lose my data connection.  The little BlackBerry logo in the status bar will disappear, and I can not use anything that requires data (email, BBM, browser, etc.)  I can still make phone calls. 

 

When I go into network settings, I see I am connected to Rogers with "4g" rather than "4G" which is what it says when I have data connection.

 

This happens regardless of if I am connected to wifi or not - I can not access data even on wifi.  Also, it has happened when I am not connected to wifi at all. 

 

Rebooting the phone restores the data connection.

 

Any help would be greatly appreciated, as it's incredibly annoying to have to reboot my phone several times a day just to get my data connection working.

Retired
Cpt_Sweatpants
Posts: 3,198
Registered: ‎01-27-2010
My Device: BlackBerry Z10

Re: Data connection drops

Hi jnak,

 

When the 'G' drops to 'g', this indicates that either the device cannot connect to the data network, or the data network is no longer available.

 

I would recommend contacting Rogers for assistance with this issue.

 

Thanks.

 

-CptS

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

New Contributor
abbassabir
Posts: 6
Registered: ‎02-16-2013
My Device: Z10

Re: Data connection drops

Hi Captain Sweatpants,

 

I am also having the same issue with data connection dropping and have already been to see the carrier (Etisalat) who have stated that there are no service outages or connection issues in the area that I live in.  I have just upgraded from BB 9800 BB6 to a BB Z10.  In the past whenever the cellular signal was weak or dropped from 3G to a lower connection speed (3g, GPRS, GSM) and I was connected to WiFi, the data (BB Sign/Dots) would still be active.  With the Z10, I have the following issues

 

  1. WiFi On + Cellular (H/G/E) + BB Sign - This usually signifies that I am connected with no issues
  2. WiFi On + Cellular (h/g/e) - Emails will work but BBM doesn't or any other app that uses a data connection.  No BB Sign
  3. Cellular (H/G/E) + BB Sign - No issues here as BB sign is there
  4. Cellular (h/g/e) - No WiFi on or BB sign.  No data at all - The phone is a phone

The way that I have tried to resolve it is as follows

 

  1. Switching off WiFi - The cellular signal switches from h/e/g to H/E/G and then the BB sign appears which indicates the data is back on.  I then turn on the WiFi and all is ok
  2. Device reset - I find myself reseting the device after which the BB sign shows up again

From what I have experienced, the problem seems to occur whenever the signal strength drops from H/G/E to h/g/e or lower but if I am in a WiFi area and connected, it should be able to transfer data through this connection

 

I would really like some support on this as I have been on many forums to understand whether there are other individuals also experiecing the same issue, which does appear to be the case.

 

Look forward to your response

 

AS

New Member
PratikPatel
Posts: 1
Registered: ‎02-23-2013
My Device: Blach Berry Z10

Re: Data connection drops

Hi

 

Ive just got my Z10 today, I have inserted the micro sim in it, it picks up wifi so ive set up my email and bbm. but when i go to settings, n mobile network to switch on the mobile network, all is says is turning cellular service on, but doesn't connect. please help me and tell me whats wrong, is my device not going to work..

 

Pratik

Contributor
caribbeansun
Posts: 26
Registered: ‎04-20-2011
My Device: Z10, Playbook

Re: Data connection drops

Same issue here - data drops out randomly and stays off with the Z10

 

I have to go into Settings/Network Connections/Mobile Network and slide the "Data Services" to off and then back to on in order to restore data connection.

 

I have a Rogers account.

 

What a pain.

New Contributor
rishiserai
Posts: 3
Registered: ‎02-26-2013
My Device: Z10

Re: Data connection drops

Hi,

I have the exact same problem and my carrier is Etisalat as well.

 

However, I do not get my data service until I dont restart my phone.

 

I have been noticing when this happens and have realized that whenever i go through an elevator where I lose connection. After that, I am not able to get the data service back on until I restart my phone.

 

Blackberry, we are ready to support you as customers, but please dont make us go through this!!!

 

Its kind of like, I am now forcing myself to like blackberry :smileyfrustrated: (i dont even know why)

New Contributor
latviandancer
Posts: 3
Registered: ‎02-25-2013
My Device: BBZ10
My Carrier: Telus

Re: Data connection drops

I was having this same problem all last week. I am with Telus.

I also figured out that it would happen when I was underground with no connection. I had a great (insert sarcasm) discussion with my carrier about how the solution is to pull of my battery every time it happens, and how it is not their problem but since they "resolved" the problem there is no need to contact Blackberry.

I figured out switching Airplane Mode on and off was the fastest fix.

Fortunately, this is not an issue for me anymore. Either magical fairies fixed it, or Telus did without admitting it was a carrier issue.

I would love to find out exactly why this is happening to me and clearly others on different carriers.
New Contributor
leryan
Posts: 5
Registered: ‎02-26-2013
My Device: Blackberry Z10

Re: Data connection drops

I have the exact same problem, everytime I go into an elevator or some place with weak coverage I lose the data connection and it remains lost even when I am back to adequate coverage. The only way to get the data connection back up is to restart the device, turning off and then on the data connection does not help, only restarting the device fixes it. This is totally unpractical.. I wonder why such things never happen on my other line where I use an iphone. I love Blackberry but when are they going to start producing FINISHED products rather than trial and error with their loyal customers?

New Member
Gman77
Posts: 1
Registered: ‎03-05-2013
My Device: Z 10

Re: Data connection drops

I am with Bell and lose connection overnight. I have tried turning the network on and off but that does not help. I have to do a battery pull

New Contributor
GrimNotepad
Posts: 7
Registered: ‎05-08-2011
My Device: Z30

Re: Data connection drops

i am getting the exact same problems, 

i approached it from another angle, my home has bad cell reception so i bought a wireless router, and i noticed when this happens my router is not "seeing" the bb connected to it, yet the phone says its connected and it has an IP and all that jazz so i start mucking about with those setting while turning my mobile service completely off, but then the wifi stack keeps reporting i have no saved network and won't disconnect from my router (in its mind)

 

i seriously think it has to do with the way the Wi-Fi is interacting with the radio and it would be very nice to get a BB (aka RIM) tech to weigh in on this