Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
sureshkumareadala
Posts: 3
Registered: ‎02-28-2013
My Device: Z10

Device doesn't start - LED blinks Red

I just Got my Blackberry Z10. I connected the device to PC and continued the instrutions. Installed Blackberry Link and updated the Device software as suggested by the Blackberry Link. The device hung while updating the software. All I can see is the LED blinking Red. I tired to reload using Blackberry Link and through browser as suggested in other posts. No use.

Please help..

Please use plain text.
Forums Advisor I
Arsen
Posts: 568
Registered: ‎02-05-2013
My Device: Blackberry Z10, Blackberry Playbook 64gb

Re: Device doesn't start - LED blinks Red

Do a battery pull and wait 2 minutes and put it back in. If it doesn't load then follow the KB33480.

Please use plain text.
Contributor
bomayed
Posts: 12
Registered: ‎02-28-2013
My Device: z10

Re: Device doesn't start - LED blinks Red

It happened to me just now , I clicked on update Device software , now all I have is a blinking LED. I have tried everything on Windows PC , Imac , waiting for 5 minutes without a battery attached.

Nothing seams to work ! Help
Please use plain text.
Contributor
bomayed
Posts: 12
Registered: ‎02-28-2013
My Device: z10

Re: Device doesn't start - LED blinks Red

ok this resolved my issue (click here )

Please use plain text.
Visitor
micheldun
Posts: 1
Registered: ‎04-12-2013
My Device: Z10

Re: Device doesn't start - LED blinks Red

I am having the same problem, but when I click on the link that solved yours it says my access is denied and I don't have sufficient privileges to view the post.

Please use plain text.
Developer
torpesco
Posts: 121
Registered: ‎01-29-2011
My Device: Z10, PlayBook

Re: Device doesn't start - LED blinks Red

Same. If you can access that link still, mind sharing what it suggested?

Please use plain text.
New Member
mitmitch
Posts: 1
Registered: ‎01-16-2014
My Device: Z10 STL100-1

Re: Device doesn't start - LED blinks Red

Try to pull your SD CARD

and then try to reload by BB Link

this work for me

Please use plain text.