If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Regular Contributor
monkeno
Posts: 62
Registered: ‎09-25-2011
My Device: 9800
My Carrier: O2

Email gets worse: "An unexpected problem occurred with ... "

I hadn't gotten any email for a few hours which is odd, so I fire up the laptop to find a dozen or so. Two of which I recall having on my Z10 but are now gone.

 

I checkthe server all the messages are still there and marked unread.

 

I look under Edit Account and find in red letters: An unexpected problem occurred with ... then the address. Some features may not be working correctly.

 

Ironically my first thought was why didn't the dumb bas$%#rds push that to Notifications.

 

Of course then followed by, Oh **bleep** ...

 

Contrary to all the well wishers here, I am telling you this thing can't reliably do standard Imap email.

 

I tried to just change some data in the account config and resave but it is having none of it. I will delete the account and start over.

 

Any one else seen this yet?

 

 

Please use plain text.
Regular Contributor
monkeno
Posts: 62
Registered: ‎09-25-2011
My Device: 9800
My Carrier: O2

Re: Email gets worse: "An unexpected problem occurred with ... "

[ Edited ]

I deleted the account with the error, but 'my server wasn't available' with the Imap config when I tried to add it. So I changed it to the Pop server config and port and it re-established and got my mail. It is still acting like Imap however and erasing from the server on delete, which is interesting.

 

I had to delete and re-establish all of the accounts on that server as none of them were working but didn't show the same message. The message did show up on the first one I established.

 

Hope this helps somebody.

 


Just discovered that the side affect to this nicety is no folders.

 

 

Please use plain text.
New Member
CTS-IT
Posts: 1
Registered: ‎05-09-2013
My Device: Z10
My Carrier: Fido

Re: Email gets worse: "An unexpected problem occurred with ... "

I had the same problem but with a POP account, and experience that in one of my ten accounts configured as a POP account my Z10 will delete messages from the server.

To fix the problem, I removed the POP account in question, restarted the Z10 and recreated the account again as a POP account.

 

I hope this helps.

Please use plain text.
New Contributor
StewBerry13
Posts: 4
Registered: ‎10-28-2013
My Device: Z10
My Carrier: Bell Canada

Re: Email gets worse: "An unexpected problem occurred with ... "

I'm having the same problem.

 

My personal e-mail is accessed via IMAP/SSL which started giving me that very error message after I applied the 10.2 update.

 

I thought it was a glitch so I deleted the account, restarted the device and am now trying to re-add the account to no avail.

 

Every time I try to add the account, no matter what I try, I always get the same "An Unexpected Error Occurred with .... " and it won't save the account.

 

I'm logged into my mail server and I can see the BlackBerry connecting to my IMAP server each and every time, however it just refuses to save the account.

 

I also have POP3 access so in a pinch I deciced to try that, just in case, but that's not working either.

 

With such a limited, frankly useless error message I find I'm at a loss to diagnose the problem further. Is it a BlackBerry issue? A Bell (carrier) issue? An ISP issue? (n.b. I've tried it from both home and work, both on and off my local WiFi networks so I doubt that very much).

 

Compounding my frustration is the fact that my work account (also IMAP/SSL) works perfectly fine (that account migrated over in the upgrade and continues to work seamlessly).

Please use plain text.
New Contributor
kpowick
Posts: 3
Registered: ‎04-05-2013
My Device: Z10
My Carrier: Telus

Re: Email gets worse: "An unexpected problem occurred with ... "

I too have the Z10, and after updating to 10.2, my only two email accounts (IMAP) can no longer receive messages.  I am able to send mail from my phone, but nothing has come in since 29 October.

 

When I look into the settings for the accounts, I also see the near useless error message "An unexpected problem occurred with .... "

 

Of course, email works on all my other computers/devices, and it was working perfectly well on my Z10 before the 10.2 update.

 

I haven't yet tried deleting and re-creating the accounts but hey, it's the weekend. Why not sit around and waste it trying to figure out how to fix a problem created by the vendor?

 

It's quite ironic that the introduction of the Priority Hub, killed my email.  I'm quite unhappy about it.

Please use plain text.
Forums Advisor I
scrannel
Posts: 740
Registered: ‎04-01-2009
My Device: Z10 10.2.1.2228
My Carrier: T-Mo USA

Re: Email gets worse: "An unexpected problem occurred with ... "

The usual fix for Email Gone Bad, is indeed to delete and reinstall the account.
Please use plain text.
New Contributor
StewBerry13
Posts: 4
Registered: ‎10-28-2013
My Device: Z10
My Carrier: Bell Canada

Re: Email gets worse: "An unexpected problem occurred with ... "


scrannel wrote:
The usual fix for Email Gone Bad, is indeed to delete and reinstall the account.

scrannel;

 

What do we do when we're not able to reinstall the account because we get the same error message?

Please use plain text.
New Contributor
niamhief
Posts: 7
Registered: ‎02-25-2013
My Device: Z10
My Carrier: Vodafone UK

Re: Email gets worse: "An unexpected problem occurred with ... "

I have this problem too - doesn't matter how many times you delete or reinstall the account it is just not getting emails.  Nothing wrong with me using imap on the same account on my laptop and it was fine before the 10.2 update.  This is total rubbish...c'mon guys - I need my email on my 'smart'phone - is it too much to ask?

Please use plain text.
New Contributor
kpowick
Posts: 3
Registered: ‎04-05-2013
My Device: Z10
My Carrier: Telus

Re: Email gets worse: "An unexpected problem occurred with ... "

[ Edited ]

I found the solution to my problem on a different Blackberry community forum.  I too had deleted and re-created my mail accounts serveral times to no avail.

 

The solution was, in the email account setup, remove the value for the IMAP Prefix.  Previously, for me, it was set to INBOX.

 

Having the prefix INBOX was part of my pre 10.2 configuration and it worked fine.  It is also used in other IMAP mail clients that I have.  Why the 10.2 version of BB email doesn't "like" it, I do not know.

 

Hopefully, this helps some others.

 

Please use plain text.
New Contributor
StewBerry13
Posts: 4
Registered: ‎10-28-2013
My Device: Z10
My Carrier: Bell Canada

Re: Email gets worse: "An unexpected problem occurred with ... "

I responded in the other thread, but I'll post here with more detail;

 

With the IMAP folder prefix option being broken in 10.2 it means my BlackBerry is now downloading my entire home directory on my mail server which comprises of several thousand files. This has slowed my BlackBerry hub to an absolute crawl to the point where it's unusable.

 

This is completely broken and renders e-mail on my BlackBerry totally unusable. I need to know how we can raise this issue to the attention of BlackBerry developers so this can be fixed immediately.

Please use plain text.