Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
PhilMaddocks13
Posts: 3
Registered: ‎02-01-2013
My Device: BlackBerry Z10
My Carrier: EE

Manual Email Sync Bug on the Z10

I am experiencing a problem syncing my email with my new blackberry manually. I have added my gmail account, gmail CARDDEV for my contacts, hotmail (email only) and my work email using microsoft exchange. I have all of them set to sync manually since I work in front of a computer all day and only need email on my phone outside of work.

 

However when I go to my email account inside the hub and press refresh, nothing happens. No update at all. I the connected to my wi-fi and on connecting it synced my emails. I thought great, problem solved. however i went to check my emails an hour later..pressed refresh..nothing...checked online and I had several emails that should of been downloaded. I changed my sync settings from manual tp an interval and back again so I could re save them, and it synced as son as is verfiyed. But the refresh function in the hub does not seem to work at all for any of my email accounts (or facebook accounts for that matter). When I do press refresh, I get no icons or any signs that the device is doing anything at all. no spinning circle..no "last synced at" information which I was used to from my android device

 

Since this is a communication device, email is pretty important. Anyone havd any ideas?

 

Please use plain text.
BlackBerry Technical Advisor
-BD-
Posts: 487
Registered: ‎05-15-2008
My Device: Z10
My Carrier: Rogers

Re: Manual Email Sync Bug on the Z10

I switched my mail to manual and am seeing the same behavior now. Haven't found a way to get new mail other than by adding a sync interval yet.  

Please use plain text.
New Contributor
PhilMaddocks13
Posts: 3
Registered: ‎02-01-2013
My Device: BlackBerry Z10
My Carrier: EE

Re: Manual Email Sync Bug on the Z10

Hi,

 

thanks for testing this. It must be a bug then if its across more than just my own device. Better to pick these things up early rather than later. Hopefully when BB start rolling out updates, this can be fixed. 

 

Also, as a suggstion, a spinning circle or anything when syncing manually by refreshing would be great so its easy to spot when the device is actually doing the syncing we have asked it to do. Becuase I am never sure if my device is updating when I've asked it to or not. Or a "last synced" time or something. 

Please use plain text.
BlackBerry Technical Advisor
-BD-
Posts: 487
Registered: ‎05-15-2008
My Device: Z10
My Carrier: Rogers

Re: Manual Email Sync Bug on the Z10

I will need to do some more testing.  When i checked again my account showed not connected and after I entered the password I can't replicate the behavior anymore.

Please use plain text.
New Contributor
PhilMaddocks13
Posts: 3
Registered: ‎02-01-2013
My Device: BlackBerry Z10
My Carrier: EE

Re: Manual Email Sync Bug on the Z10

Hi there.

 

I am still suffering the same issues. I can get email to sync when on push, and when intervals are set, however when intervals are set, it will ONLY sync on the interval and not when refresh is pressed. The refresh function doesn't seem to work at all on any account (social media ones included). 

 

I have reset the phone (security wipe), however this has not sorted the problem. 

 

The same issue has been mentioned a few times on crackberry by different people, so I am led to believe that this is a bug with the hub. 

Please use plain text.
New Member
nickbreeze
Posts: 1
Registered: ‎02-24-2013
My Device: BlackBerry z10
My Carrier: everything everywhere uk

Re: Manual Email Sync Bug on the Z10

I have the same issues for all accounts including exchange, Hotmail, Gmail, Facebook, Twitter, whether on wireless or network. Like the person above I don't need regular sync intervals, but I do need manual sync to work.
Please use plain text.
New Member
jadenic1
Posts: 1
Registered: ‎02-26-2013
My Device: BB Z10
My Carrier: Vodacom SA

Re: Manual Email Sync Bug on the Z10

Hi I can confirm this is not a bug limited to you guys only, I have also tried to do a manual refresh but nothing works over mobile network. It does seem to work over wifi, so just for clarity with sync interval on any account set to manual upon hitting refresh nothing happens (confirmed as not syncing to point of checking exchange account logs and no syncing is occuring with the server), changing this from manual sync interval to set time interval ie. 15min produces desired result of sync. Needs to get fixed for a top end communication device this is a bug which users with heavy email mailbox best stay clear of as right now you only have automated time sync interval so your inbox will continue to fill whilst you have no control over it....ie fix the manual refresh bug.

Please use plain text.