Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Guru I
John_Clark
Posts: 14,765
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.2.1.3247; PlayBook w/OS 2.1.0.1917
My Carrier: at&t
Accepted Solution

Missing Voicemail Indicator

I have a Z10 I got from the launch event.  I'm using my T-Mobile US sim card.  When someone leaves me a voicemail I get a popup message but no other voicemail indicator anywhere on the device. 

 

Anyone else seeing this?

 

 

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
Guru I
John_Clark
Posts: 14,765
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.2.1.3247; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Missing Voicemail Indicator

[ Edited ]

So, I've solved this myself. After inserting my TMobile sim card I've rebooted several times and the hub entry for Voicemail hasn't shown up.

Since noticing it not working, I left a test voicemail. It gave me a popup message that I dismissed. Still nothing in the hub. I then removed the battery and rebooted and now the voicemail entry is in the hub and it seems to be working.

However, visual voice mail still wasn't working. If you had visual voice mail before you switched to the Z10 you will need to go into the Phone settings and set up visual voicemail.  If you didn't you'll need to contact your provider to make sure the feature is enabled, if available.

Go to the Phone app.

Swipe down from the top and touch on settings.

Go toVoice Mail There should be a button for visual voice mail. It may ask you to call your voicemail to set it up. Tap on the "call" button at the top right corner. Once it answers and you hear that you have messages, simply hang up.

That should complete the setup for visual voice mail.

 

Enjoy!

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
Contributor
arby1970
Posts: 11
Registered: ‎04-02-2011
My Device: Z10
My Carrier: Bell mobility

Re: Missing Voicemail Indicator

So I've had my Z10 for a week now, I am just finding out that I have no way of seeing if I have a voicemail waiting. I thought it was just a quiet week.

I've read that some people have a voicemail option in their Hub, but I don't.

Have I missed something simple or is this a bigger issue?

Please use plain text.
Guru I
John_Clark
Posts: 14,765
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.2.1.3247; PlayBook w/OS 2.1.0.1917
My Carrier: at&t

Re: Missing Voicemail Indicator

Does your carrier offer visual voicemail? If so, have them set it up and then go to the phone app, swipe down from the top, and go to settings. There should be an option for visual voicemail setup.
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Please use plain text.
Contributor
arby1970
Posts: 11
Registered: ‎04-02-2011
My Device: Z10
My Carrier: Bell mobility

Re: Missing Voicemail Indicator

the visual voicemail is a paid option with Bell Mobility.  On my 9700 I would get a text message on a new voicemail as well as the indicator on my home screen.

Not a deal breaker by any means, just more curious as to why this doesnt happen anymore.

I will give Bell a call, maybe this isnt a Z10 issue.

Please use plain text.
New Contributor
bbfish
Posts: 4
Registered: ‎03-30-2013
My Device: Z10 2256
My Carrier: ATT

Re: Missing Voicemail Indicator

Had the same problem on new Z10. I had used BBlink to transfer everything from previous BB Bold right from the start. After a few days I figured out there was no VM in the HUB or by LED but I had several voicemails.

Called ATT who couldn't figure it out. Did a security wipe (hard reset) and it started working as expected. However, I had not restored from BBLink yet. After another Restore, it quit working again. Did another wipe but did not restore with BBLink - had to transfer info in by other means. Apparently there was a setting from the old phone that was transferred in by BBLink which causes this problem. Hope this helps others. 

Please use plain text.
New Contributor
JJShupick
Posts: 5
Registered: ‎04-10-2013
My Device: BlackBerry Z10
My Carrier: AT&T

Re: Missing Voicemail Indicator

I had the same issue and I did the wipe and now have normal Voice Mail indicators (MWI) but no Visual Voice Mail. How do we get Visual Voice Mail back as I know I have the service.
Please use plain text.
New Contributor
JJShupick
Posts: 5
Registered: ‎04-10-2013
My Device: BlackBerry Z10
My Carrier: AT&T

Re: Missing Voicemail Indicator

Just got off the phone with AT&T again. and they updated my plan code to a new one for the Z10 and turned off my phone while the change was happening. I did have to re-setup my voice mail but VVM is now working perfect. I really wonder if they would have changed my plan first I could have kept my restore instead of starting from scratch.

Please use plain text.
New Contributor
bbfish
Posts: 4
Registered: ‎03-30-2013
My Device: Z10 2256
My Carrier: ATT

Re: Missing Voicemail Indicator

No. ATT originally did the same for me but it did not fix the indication problem. Still needed the security wipe afterward.

I believe the problem is in BBLink.

Please use plain text.
New Contributor
JJShupick
Posts: 5
Registered: ‎04-10-2013
My Device: BlackBerry Z10
My Carrier: AT&T

Re: Missing Voicemail Indicator

After my Wipe I just had basic voice mail and the MWI was working.
Well I did a restore back to my yesterday backup when my VVM didn't work and my VVM still works now. I can try and find out what plan code they used if it will help you. From what I see on my end they changed me to DataPro Enterprise 5GB for BlackBerry(R) 4G LTE with Visual Voicemail. I can find the actual Plan code if you need me to.
Please use plain text.