Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
gbab
Posts: 11
Registered: ‎04-13-2013
My Device: Blackberrry Z10

No sound on Device

HI there i have been experiencing a sond problem on my Z10. Randomly my speaker will just stop working, i cant play music, alarm doesnt go off, phone doesnt ring, or anything, in addition the vibrate doesnt seem to work either.

I initially thought it was a software problem, but i have recently updated my software to 10.0.10.99 and the problem still persists. the only way to fix it is to restart or pull the battery.

 

i dont use a bluetooth device, but i do use wifi. i recently read a thread that said one should delete all bluetooth paired devices and restart to get it to work, so i am waiting to see if it happens again.

 

Is this a Software issue? should i be concerned?

 

Thanks

Retired
Cpt_Sweatpants
Posts: 3,198
Registered: ‎01-27-2010
My Device: BlackBerry Z10

Re: No sound on Device

Hi gbab,

 

When you use your volume keys, does the volume display appear on the screen?

 

Thanks.

 

-CptS

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

Contributor
gbab
Posts: 11
Registered: ‎04-13-2013
My Device: Blackberrry Z10

Re: No sound on Device

Hi there, yes it does indeed appear on screen, it's not just the volume all notifications don't work, and normal mode is active and volume is up.
Retired
Cpt_Sweatpants
Posts: 3,198
Registered: ‎01-27-2010
My Device: BlackBerry Z10

Re: No sound on Device

Have you tried using a set of wired headphones to see if the sound/music will play through them?

 

Thanks.

 

-CptS

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

Contributor
gbab
Posts: 11
Registered: ‎04-13-2013
My Device: Blackberrry Z10

Re: No sound on Device

Hi, I have tried that, but still no sound. I did notice though that when I put the volume to max I an hearing some static through the speakers and earphones.
Retired
Cpt_Sweatpants
Posts: 3,198
Registered: ‎01-27-2010
My Device: BlackBerry Z10

Re: No sound on Device

Can you try performing a backup, via BlackBerry Link, then perform a security wipe and test it again? It sounds like a software issue as the updates for the BlackBerry Z10 only install updated components and does not re-install the entire operating system as in past devices.

 

Thanks.

 

-CptS

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

Contributor
gbab
Posts: 11
Registered: ‎04-13-2013
My Device: Blackberrry Z10

Re: No sound on Device

I did do this about 3 days ago and the problem still persists, should I try and do this again?

Please let me know, thanks
Contributor
gbab
Posts: 11
Registered: ‎04-13-2013
My Device: Blackberrry Z10

Re: No sound on Device

I did my reset using the online updater, is there a difference?