Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
Posts: 2
Registered: ‎12-03-2013
My Device: Z10
My Carrier: Bell mobility

Re: Problem with sensors on Z10

mine stopped working yesterday also only thing i did was download the game shark attack from the 25 days of xmas compass and rotate not working

Forums Advisor II
Posts: 861
Registered: ‎04-01-2009
My Device: Z10 10.2.1.3247
My Carrier: T-Mo USA

Re: Problem with sensors on Z10

New Member
Posts: 1
Registered: ‎12-03-2013
My Device: Blackberry Z10
My Carrier: AT&T

Re: Problem with sensors on Z10

Gonna chime in here with no other relevant information other than it started happening after I downloaded that film from BlackBerry World yesterday morning too. Annoying but definitely a software problem by the looks of it so it's just a massive annoyances e for now in my opinion.
Contributor
Posts: 24
Registered: ‎04-22-2011
My Device: Blackberry Playbook 32GB and Z10
My Carrier: Rogers

Re: Problem with sensors on Z10

OK based on feedback from Crackberry and my own personal experience turning off location services and then rebooting the phone seems to get the sensors working again.

 

Before I couldn't go more than 2 mins without sensor failure after a reboot.  Now after turning off location services and rebooting my phone has gone 40+mins so far without sensor failure.

New Member
Posts: 1
Registered: ‎12-03-2013
My Device: Z10
My Carrier: Rogers

Re: Problem with sensors on Z10

My Z10 stopped rotating about 5 hours ago.  Same issues as everyone above.  Rotated for 1 -2 minutes after reboot.  

 

Turning off location services and rebooting seems to be doing the trick.

 

Thanks to everyone that posted solutions

Forums Advisor II
Posts: 861
Registered: ‎04-01-2009
My Device: Z10 10.2.1.3247
My Carrier: T-Mo USA

Re: Problem with sensors on Z10

[ Edited ]

Yup Question is, why? I can sort of get the rotation and all as the compass may have to have location services on to work (or, in this case, not). But how would that explain the screen brightness going crazy?

Trusted Contributor
Posts: 156
Registered: ‎11-20-2011
My Device: playbook 16g,32g, 64g (use this every day still), 2-z10's, Passport
My Carrier: Telus

Re: Problem with sensors on Z10

I have seen links for downloading 10.2.1  but mega won't open and the others seem to want info I'm not willing to give.  Can you explain how you did the download

Contributor
Posts: 24
Registered: ‎04-22-2011
My Device: Blackberry Playbook 32GB and Z10
My Carrier: Rogers

Re: Problem with sensors on Z10

Apparently the problem was fixed just reboot and all should be good. The problem was apparently on BlackBerry's end. 

New Contributor
Posts: 3
Registered: ‎12-03-2013
My Device: Z10
My Carrier: Wind

Re: Problem with sensors on Z10

I uninstalled shark attack and rebooted. Ben working for a few hours now.
Contributor
Posts: 27
Registered: ‎06-28-2012
My Device: BOLD 9900-Z10
My Carrier: VODAFONE TR

Re: Problem with sensors on Z10

Problem was fixed by blackberry. It is not about any app. Now, just reboot your phone :smileywink: