Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5

SMTP API faulty on BB Z10

The SMTP API implementation RFC 821 on BB Z10 seems to be faulty.

 

I am trying to configure IMAP / SMTP with my domain. While gmail and web.de are working fine with SMTP, I always get an error using my own domain sending SMTP Mails via port 25, 587 with or without StartTLS/SSL. All SMTP Mails are dropped.

 

Starting to find any error message in the smtp logs.

 

Several times I see the error "Stray newline from" in SMTP traffic. Sounds like lines aren't terminated correctly with \r\n (0x0d, 0x0a).

 

Starting to capture all smtp traffic in hex.

 

When I look into both header and smtp commands everything seems to be correct.

 

In the body then I find oddities.

 

The body starts correctly with newline 2x 0d0a and ends correctly with 0d0a 2e 0d0a.

But all other 0a (\n) in the body aren't completed with 0d (\r). This seems to be wrong implementation of RFC 821 and my smtp server drops all messages of this kind. In this case all BB Z10 smtp mails.

 

Seems that Z10 smtp api allows to type body directly without terminating the body one layer before.

 

Can't imagine that Blackberry isn't able to implement rfc 821 correctly. But it looks like.

 

:-(

Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5

Re: SMTP API faulty on BB Z10

I'm actually using Blackberry 10 Softwareversion 10.0.10.90.

Forums Advisor III
drewread
Posts: 1,035
Registered: ‎02-07-2013
My Device: Z10

Re: SMTP API faulty on BB Z10


anzoro wrote:

I'm actually using Blackberry 10 Softwareversion 10.0.10.90.


Is that a publicably available "approved" software release, or a beta?

-: DrewRead :-
Can't find an app on Blackberry World yet? Tweet the developer and ask when they will #GetWithBB10 !!
"Like it" if you like it. :smileyhappy:
Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5

Re: SMTP API faulty on BB Z10

It's the publically approved software release from Vodafone DE.

Softwareversion: 10.0.10.90

OS Version: 10.0.10.690

Build-ID: 447500

 

I'm sure if you capture the smtp traffic you will find the same mistakes in the body implementation.

Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5

Re: SMTP API faulty on BB Z10

The workaround mentioned in this thread doesn't work for me:

 

http://supportforums.blackberry.com/t5/BlackBerry-Z10/POP3-Business-E-Mail-CANNOT-SEND-HELP-PLEASE/t...

 

I tried to use smtp with port 25 without STLS, SSL and without wlan but I can't send mails, all mails are dropped.

 

Any ideas?

Forums Advisor III
drewread
Posts: 1,035
Registered: ‎02-07-2013
My Device: Z10

Re: SMTP API faulty on BB Z10

You will need to call your carrier and ask them for their mobile SMTP server (if they have one), as the Rogers one is only useable for Rogers customers.

-: DrewRead :-
Can't find an app on Blackberry World yet? Tweet the developer and ask when they will #GetWithBB10 !!
"Like it" if you like it. :smileyhappy:
Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5

Re: SMTP API faulty on BB Z10

I'm not using the smtp server from my carrier. I'm using the smtp server from my domain hoster. And it is not Rogers. It is like mail.myowndomain.com.

 

My domain hoster has found out in their smtp traffic logs, that the Blackberry Z10 uses wrong smtp implementation.

My domain hoster captures the smtp traffic log and found the error.

 

On the Playbook OS 2.1 everything works fine.

Exactly the same configuration on BB Z10 doesn't work.

 

So there have to be a wrong implementation on BB Z10.

New Developer
michaelst
Posts: 5
Registered: ‎03-08-2013
My Device: Z10

Re: SMTP API faulty on BB Z10

Hi anzoro,

you said that "web.de" is working for you. Can you please tell me your settings, because for me it is not working like it should do (I come from a iOS and on my iPhone everything is fine).

I am able to receive messages via IMAP and send them, but sent messages from my Z10 are put into a folder "SENT" and not where they should be placed in "Gesendet". Do you have a solution for that?

Another point is that Push is not really working. Sometimes I get emails very late (e.g. half and hour) and sometimes I can only get them by refreshing the Hub.


Best regards,
Michael
Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5

Re: SMTP API faulty on BB Z10

web.de settings:

 

username for imap and smtp: youraddress@web.de

 

imap

server: imap.web.de

Port: 993

SSL

 

smtp

server: mail.web.de

port: 587

StartTLS

 

For me it doesn't matter if i user wlan or not. Both are function.

Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5

Re: SMTP API faulty on BB Z10

Definitely no one including Blackberry able to capture the smtp traffic to find the same problems in mail bodys?