Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5
My Carrier: Vodafone DE

Re: SMTP API faulty on BB Z10

Still waiting for any other ideas.

Using my providers smtp in mobile doesn't work.

Please use plain text.
Contributor
carsonblue
Posts: 13
Registered: ‎03-08-2013
My Device: z10
My Carrier: o2

Re: SMTP API faulty on BB Z10

I have the exact same issue and I have the same domain setup - I'm guessing your's is also register.com. I cannot find a fix and no updates have been issued , I really wish I hadn't updated

Please use plain text.
Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5
My Carrier: Vodafone DE

Re: SMTP API faulty on BB Z10

Ok, I'm not the only one with this issue. Thanks for your post. Anyone else?

 

It's not register.com. It's myfirstnamemylastname.de ;-)

 

But I also have no fix nor update :-(

Please use plain text.
Contributor
carsonblue
Posts: 13
Registered: ‎03-08-2013
My Device: z10
My Carrier: o2

Re: SMTP API faulty on BB Z10

I have read other forum posts on this and it appears that the usual port 587 that worked fine before the update is the problem. I do not know what the answer is , I also cannot use a carrier smtp. There must be an easy ( to BBRY) fix for this or a minor patch to help us out.

Please use plain text.
Forums Advisor III
drewread
Posts: 1,034
Registered: ‎02-07-2013
My Device: Z10
My Carrier: Rogers

Re: SMTP API faulty on BB Z10

Maybe a silly question, but have you all tried turning on SSL and using port 465? It's been working great for me the whole time..
-: DrewRead :-
Can't find an app on Blackberry World yet? Tweet the developer and ask when they will #GetWithBB10 !!
"Like it" if you like it. :smileyhappy:
Please use plain text.
Contributor
carsonblue
Posts: 13
Registered: ‎03-08-2013
My Device: z10
My Carrier: o2

Re: SMTP API faulty on BB Z10

Thanks - tried that and it says cannot reach server on 465. It will save setting on 587 but will not send mail.

Please use plain text.
Contributor
OmniT
Posts: 25
Registered: ‎03-11-2013
My Device: 9650

Re: SMTP API faulty on BB Z10

[ Edited ]

This is a known issue, it appears to have been introduced with at least the following recent software version bundles for the Z10:

 

10.0.10.85 (Canada)

10.0.10.82 (Middle East/South Asia)

10.0.10.90 (Europe)

 

Blackberry is aware of the issue and has stated that they plan to release a fix in a future software release.

 

In the meantime, one possible workaround that appears to work for some people is using unauthenticated SMTP, ie remove the username and password in the SMTP settings.

 

However that is a security risk and therefore you will only be able to use that with a mail server provided by your home mobile carrier, if they in fact provide that service.

 

Another workaround would be to use an alternative email client for sending (ie K-9 Mail, an Android port available in Blackberry World), or use a different connection method. (ie IMAP, or Exchange ActiveSync.)

 

Please see the following post and the link within it to the main discussion over on Crackberry.com:

 

http://forums.crackberry.com/blackberry-z10-f254/heads-up-email-bug-recent-z10-os-versions-779341/

 

There are also several threads on the official Blackberry forums here about it. Here is one:

 

 

 

 

 

Please use plain text.
New Contributor
Netfox
Posts: 2
Registered: ‎03-11-2013
My Device: Blackberry Z10
My Carrier: Bell Canada

Re: SMTP API faulty on BB Z10

[ Edited ]

Can't just be from the update, mine's been doing this since I got it.  And my upgrade only came 2 days ago.

 

Edit: And as I read more about it, it was also from previous builds as well. 

Please use plain text.
Contributor
OmniT
Posts: 25
Registered: ‎03-11-2013
My Device: 9650

Re: SMTP API faulty on BB Z10

I do believe some people had problems early-on, those problems were harder to pinpoint than the cases where something had worked fine for 2-3 weeks and then right after the update stopped working.

 

One issue that I believe is probably related pertains to timestamps - various Z10 users reported that emails generated by the Z10 were missing timezone offset information in the email headers, which caused various timestamp anomalies.

 

In general I think Blackberry just has to overhaul their SMTP message formatting. :smileyhappy:

Please use plain text.
Contributor
anzoro
Posts: 46
Registered: ‎04-19-2010
My Device: BB Playbook, BB Torch 9800, BB Z10, iPhone5
My Carrier: Vodafone DE

Re: SMTP API faulty on BB Z10

"Blackberry is aware of the issue and has stated that they plan to release a fix in a future software release."

 

Sounds to be something officially.

 

Hopefully we have not to wait until autumn for a patch.

Please use plain text.