Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
Zouyu
Posts: 11
Registered: ‎03-28-2013
My Device: Z10
My Carrier: Fido
Accepted Solution

There's red exclamation mark in battery icon when connected to Thinkpad T420

I'm new here and this Z10 is my first BlackBerry smartphone.

I noticed that when I took it out of the box and connected it to my Thinkpad T420 which was running Windows 8, it started to charge the battery, and it was okay, and then I installed the BlackBerry Link that comes with it, and after I rebooted my laptop, there's a red exclamation mark in the battery icon, and it seemed that it stopped to charge the battery.

 

I uninstalled the BlackBerry Link and after reboot, it started to charge the battery again.

 

I'm not sure if it's a bug or not.

 

Thanks.

Please use plain text.
Forums Advisor III
jerryg50
Posts: 1,178
Registered: ‎02-28-2009
My Device: Torch, Bold, Play Book, and Bluetooth HS-700
My Carrier: BELL

Re: There's red exclamation mark in battery icon when connected to Thinkpad T420

I have not tried the phone with Windows 8.

 

I am trained on Win 7 tech support, and I am doing tech support for Windows 7.  At this time I have no training for Win 8 support.  If your device is running Windows 8 - RT, I would put a strong bet on a compatibility problem with the Link drivers for the phone. If the device is running the standard Win 8 OS, then I would be enclined to think it is a hardware compatiblity problem of some type. From what I read Link is supposed to work with Win 8. I don't know about RT.

 

 

Read on...

 

I believe from the way Link installed on the Win 7 systems it comes with its own drivers. I never looked very closely in to this because I never had an issue with Link using Win 7.  I did have some issues with XP on some older computers. Without the Link software installed Win 7 installs its own generic drivers.

 

I also found with Win 7 computers that have the old Desktop manager installed, those drivers also work with the Z10 for charging, and being able to read the SD card and the phone's memory via the USB port. Desktop Manager software will not work with the Z10.

 

Try this if you can do it in Win 8.  Install the Link software. Go to the System Device Properties with the BB phone connected.  Uninstall the phone in the hardware section. This should uninstall the drivers. Re-start the computer with the phone remaining powered on and connected. I am gambling if the Win 8 BB drivers will get installed rather on the restart than the Link drivers. I never tried this with Win 8. It may be worth the shot.

 

Another interesting thing to try if this does not work, connect the Z10 using an external powered USB HUB between it and the computer. The HUB will act like a buffer. Maybe the OS will react differently this way.  I have had issues where a powered USB HUB solved some issues with specific USB devices. This was more with printers, GPS devices, and scanners.

 

Another issue is I believe your Thinkpad works more like a tablet than a full blown computer. This may be an issue with the Link software. It would be interesting to know if anyone else who is reading this, is using the Link software on a desktop or full blown laptop that is running Win 8. If so, and there are no issues this should narrow the problem down to the T420, rather than the Win 8 system or the Link software itself.

 

Another interesting thing to look at is if while the phone cannot charge, is the Link software able to read the phone just the same?  If so, you may have to live with the fact you can backup and restore the phone with the T420, but not charge it.

 

If you sync the phone to Hotmail, you will have a form of a backup for your contacts and I believe also the data. I tried the phone sync with Yahoo and Gmail. Gmail had a lot of issues. Yahoo worked but not great. I found Hotmail worked the best with the Z10 for syncing. 

 

If you have Outlook you can install the Outlook Hotmail sync tool. This is available from the MS site. It is called Outlook Connect if I remember right. This way you can set up MS Outlook to sync to your Hotmail account. This will keep the phone and your Outlook all synced together with Hotmail.  I am doing this with a number of Z10's with great success. You will need to make yourself a Hotmail email account. Then you will have to do some reading to get this going.

 

 

 

 

 

 

Jerry G.
Please use plain text.
Forums Advisor III
drewread
Posts: 1,035
Registered: ‎02-07-2013
My Device: Z10
My Carrier: Rogers

Re: There's red exclamation mark in battery icon when connected to Thinkpad T420

It could also be that your USB port is only putting out 500mA of juice from it, which is not enough to adequately charge the phone unless it is powered off completely or at idle. Use the supplied 750mA (or higher!) charger to charge your z10 battery until it is full. :smileyhappy:

 

-: DrewRead :-
Can't find an app on Blackberry World yet? Tweet the developer and ask when they will #GetWithBB10 !!
"Like it" if you like it. :smileyhappy:
Please use plain text.
Contributor
Zouyu
Posts: 11
Registered: ‎03-28-2013
My Device: Z10
My Carrier: Fido

Re: There's red exclamation mark in battery icon when connected to Thinkpad T420

Jerry,

Thank you for your reply and the problem's been solved as you've suggested.

 

"Install the Link software. Go to the System Device Properties with the BB phone connected.  Uninstall the phone in the hardware section. This should uninstall the drivers. Re-start the computer with the phone remaining powered on and connected. I am gambling if the Win 8 BB drivers will get installed rather on the restart than the Link drivers."

 

It's so great, I can hook up my Z10 to my Thinkpad laptop, I can sync whatever files I'd like to and it's charging the battery.

 

Have a great day.

 

Yu

Please use plain text.