Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Regular Contributor
dave-willis-cc
Posts: 55
Registered: ‎01-30-2011
My Device: BlackBerry Z10

Z10 Camera Fails to Launch

Hi all,

I have a new Z10 (less than a week old) and I used the camera this morning, took the photo and it failed to display the photo. I send the image to a mate via BBM and it wouldn't open for them. Now I have since tried to use the camera again and it fails to launch. Any ideas? I have tried restarting the phone and switching it off but to no avail.
Forums Advisor I
Arsen
Posts: 568
Registered: ‎02-05-2013
My Device: Blackberry Z10, Blackberry Playbook 64gb

Re: Z10 Camera Fails to Launch

Dave,

So I am guessing the camera icon on your home screen on the bottom doesn't work when you click it. Can you open up your pictures or movie icon, can you engage the camera from there?  You can also install a stupid third party app, pocket mirror that engages your camera.  Can you try these and get back to us..

Regular Contributor
dave-willis-cc
Posts: 55
Registered: ‎01-30-2011
My Device: BlackBerry Z10

Re: Z10 Camera Fails to Launch

The camera starts to load up, but then immediately closes, it occurred when I enabled Geo-Tagging. I have tried disabling the location based services in settings but this doesn't solve the issue. I have tried loading up from locked screen, shortcut on the toolbar and the icon on the widget screen and encounter the same problem with all ways. Now that I have installed this pocket mirror camera app it seems to be working, but for how long? I have spoken to my carrier and they said to return it and they will swap for a brand new one. But this is a lot of hassle to reinstall all the apps and such again and then to fit a new screen protector. I have tried uninstalling the pocket mirror app and it is still working. This shouldn't be something that you have to do to get the device to function correctly.
Forums Advisor I
Arsen
Posts: 568
Registered: ‎02-05-2013
My Device: Blackberry Z10, Blackberry Playbook 64gb

Re: Z10 Camera Fails to Launch

Definetly sounds like more an OS related issue than hardware. I am guessing an app might have screwed up something. I would uninstall any app that uses the camera and re-install it..

Regular Contributor
dave-willis-cc
Posts: 55
Registered: ‎01-30-2011
My Device: BlackBerry Z10

Re: Z10 Camera Fails to Launch

The only app that I'm aware that uses the camera is the native camera, possibly FourSquare as well but that has been installed the whole time I've had the device and not had a problem until this morning.
Forums Advisor I
Arsen
Posts: 568
Registered: ‎02-05-2013
My Device: Blackberry Z10, Blackberry Playbook 64gb

Re: Z10 Camera Fails to Launch

Would you consider a secure swipe?

Regular Contributor
dave-willis-cc
Posts: 55
Registered: ‎01-30-2011
My Device: BlackBerry Z10

Re: Z10 Camera Fails to Launch

That was the only resolution I could think of. I will attempt it when I get home.