If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Member
jjclarke
Posts: 1
Registered: ‎03-25-2013
My Device: Z10
My Carrier: Etisalat

Z10 SMTP Email Sending Issues

Hello
 
Could you let me know if you have a workaround for the issue with not being able to send SMTP emails from the new Blackberry Z10 on build 10.0.10.82
 
The message I get is 'Protocol Layer was unable to send a message'
 
There is an ever growing discussion on the message boards….
 
 
 
 
I have tried the following;
  • Using a different port for smtp (currently using 465 with SSL)
  • Tried turning SSL off and using port 25
  • Tried using a local smtp from my service provider (Etisalat raher than auth.smtp.1and1.co.uk)
  • Using a different email
None of the above work.
 
Any assistance much appreciated...
Please use plain text.
Contributor
6hugo9
Posts: 10
Registered: ‎04-01-2011
My Device: Blackberry Z10
My Carrier: O2 (UK)

Re: Z10 SMTP Email Sending Issues

Yes please -- it's annoying that March-2013 update has introduced such a crippling facility.

 

I have IMAP and Exchange accounts setup, and all of my email accounts suffer this problem every day ..

 

Quite dibilitating - and not good when this is my primary communication device... I dont look forward to having to resort to an Android based phone if this doesnt get fixed fairly soon  :smileysad:

 

Regards

 

Please use plain text.
Forums Advisor III
drewread
Posts: 1,034
Registered: ‎02-07-2013
My Device: Z10
My Carrier: Rogers

Re: Z10 SMTP Email Sending Issues

[ Edited ]

6hugo9 wrote:

Yes please -- it's annoying that March-2013 update has introduced such a crippling facility.

 

I have IMAP and Exchange accounts setup, and all of my email accounts suffer this problem every day ..

 

Quite dibilitating - and not good when this is my primary communication device... I dont look forward to having to resort to an Android based phone if this doesnt get fixed fairly soon  :smileysad:

 

Regards

 


@6hugo9 - I think that you are talking about two seperate issues, unless you are also using 1&1 as your email provider.

 

@jjclarke - The 1&1 issue looks like it is being looked into, there is a KB article here. That said, the more of you that call into your Carrier's Blackberry support teams and report the issue, the more likely you are to get it resolved. You may even find that there is already a resolution in the pipeline waiting for Carrier's to OK the release of the updated software?

 

@6hugo9 - you are listing a number of seperate issues in your linked threads. There is a bug that shows up on some servers over SMTP that the z10 is botching the HTML encoding on the emails (fortunately my server are not having this issue, knock on wood!), also others are having issues with ports being blocked (port 25 is quite frequently blocked by ISPs for anti-spam reasons) which would stop email from being sent.. as you wouldn't be able to connect to your server.

 

Regardless, the best way to get to the bottom of that issue is also to call your carrier's Blackberry support team.. that will get the issue escalated on the development side. The "more the merrier", so to speak. :smileyhappy:

 

A little birdie told me that when that SMTP encoding bug was introduced, the Blackberry support teams were swamped with calls.. So one has to assume that the devs were then working hard on resolving the issue. I imagine that we are all now waiting on our carriers for the fix to be sent through after they get done with the Carrier's "OS tests" that are always delaying our software updates. :smileyhappy:

 

Best bet is always to call in and get a resolution, especially for extremely important issues like this one. :smileyhappy:

 

-: DrewRead :-
Can't find an app on Blackberry World yet? Tweet the developer and ask when they will #GetWithBB10 !!
"Like it" if you like it. :smileyhappy:
Please use plain text.
Contributor
6hugo9
Posts: 10
Registered: ‎04-01-2011
My Device: Blackberry Z10
My Carrier: O2 (UK)

Re: Z10 SMTP Email Sending Issues

@drewread - I do INDEED use 1and1 as my email provider for my non Exchange accounts ...

 

I didnt realise there was a problem with 1and1 IMAP accounts sorry...

 

I shall pester my carrier and 1and1 about the issue.

 

Thanks!

Please use plain text.
Forums Advisor III
drewread
Posts: 1,034
Registered: ‎02-07-2013
My Device: Z10
My Carrier: Rogers

Re: Z10 SMTP Email Sending Issues

No problemo. :smileyhappy: and good luck! :smileywink:

-: DrewRead :-
Can't find an app on Blackberry World yet? Tweet the developer and ask when they will #GetWithBB10 !!
"Like it" if you like it. :smileyhappy:
Please use plain text.