Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
Posts: 4
Registered: ‎05-28-2013
My Device: z10
My Carrier: MTS

Z10 to pc connection issue

I am having a problem with connecting my Z10 to my laptop via usb.

 

The laptop is running windows 7 x64

 

When i connect the phone to the computer via usb i would get a note saying the drivers were not successfully installed.  In device manager it would list under other "rim network device"

 

note: i have updated the z10 os with the patch.

 

I then tried a few solutions listed on these forums, which were:

 

1) tried to install and or connect in airplane mode - no luck

2) tried to do the install of ports as listed in "http://supportforums.blackberry.com/t5/BlackBerry-Z10/Computer-Cannot-Detect-Install-Drivers-Properl..." - this took away the error in device manager but it still does not show in computer or blackberry link.

3) attempted to install the drivers manually as listed in that same link - also no luck

4) attempted to cold boot with the Z10 connected via usb and it did load link and did see the phone, but once it loaded it, it stopped seeing the phone in any way and i still had the rim network device issue in device manager *unless this is attempted after the "port" driver was installed - i tried at both periods.

5) i have attempted link installs with various firewalls and filters off but no real change.

 

Any ideas or suggestions?  I am almost down to reloading the os on the laptop but i would rather not do that if i can avvoid as this is the only thing i am having a issue with.

Regular Contributor
Posts: 63
Registered: ‎08-19-2011
My Device: Torch 9800, Z10
My Carrier: EE

Re: Z10 to pc connection issue

Interesting..

my PC with W8 64bit doesn't see the Z10.

My laptop with W7 32bit does and I had to use that to transfer fom my 9800.

Is it an OS level problem?

New Contributor
Posts: 4
Registered: ‎05-28-2013
My Device: z10
My Carrier: MTS

Re: Z10 to pc connection issue

I thought I would report in on this issue as it is now resolved.

I found that the issue was not the z10 so much as it was some sort of corruption in the usb setup on the computer itself.

I ended up backing up my documents and other assorted things and reinstalling the os.  After reinstalling I had to load Blackberry Link before it would recognize the usb connection.

Overall I have to say I am very satsified with the phone as it is extremely capabile and does everything need it to do, with capability to spare for future uses.

Ts

 

p.s. My next adventure will be to get the phone to connect via bluetooth now that I know it can talk to it via the usb.

New Contributor
Posts: 5
Registered: ‎11-23-2012
My Device: 9900
My Carrier: 9900

Re: Z10 to pc connection issue

You could reinstall the drivers.

Regular Contributor
Posts: 63
Registered: ‎08-19-2011
My Device: Torch 9800, Z10
My Carrier: EE

Re: Z10 to pc connection issue

Corruption? The ports work fine with both usb3 and usb2 devices (including a BlackBerry 9800) so I'm puzzled why it should be the windows os. I checked for a usb driver update and it suggested it was already up to date and functioning correctly.
S
New Contributor
Posts: 4
Registered: ‎05-28-2013
My Device: z10
My Carrier: MTS

Re: Z10 to pc connection issue

I should probably clarify...

 

the USB corruption was on my laptop running windows 7x64 and not a result of the z10.  After poking around trying to originally connect my z10, i noticed that some other usb hardware (keyboard and a mouse) used to work (any would) connected to a docking station, but now only worked when directly connected to the laptop (usb2 or usb3 ports). Note: some hardware would continue to work at the docking station, provided it had been there fore a while. I also noticed a few other minor issues that pointed to the usb having a issue.  I did attempt to reinstall the drivers for the usb and it failed to install.

 

As reinstalling the os wasnt a big issue for me i went for that after backing up my data.  After installing BB Link, I connected the phone up and it worked right away. 

 

My conclusions therefore are that my usb drivers were were hooped and only a os full reinstall fixed it.