Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z30

Reply
New Contributor
GromitJK
Posts: 5
Registered: ‎11-09-2013
My Device: Z30
My Carrier: A1
Accepted Solution

Wifi connected - but no internet

Hi!

 

I´m new to Blackberry and just recieved my Z30 (which i really like a lot!)

Yet i do have a problem with the wifi connection. I managed to establish a connection to my wifi router. In the settings i see, that the connection is active. Signal is good.

 

But on the top bar i still see the 3G icon (instead of the wifi icon). I also got a message, that my wifi has only limited access to the internet.

 

I know, that the router is working, because all my other devices (for example the laptop i´m typing this message on) do have access to the internet.

 

Are there any special settings, i have to check on my blackberry z30?

I found the advanced wifi settings with lots of technical informations about the wifi connection - which of this information should i post to help solving my problem?

 

Thank you very much for your tips!

Please use plain text.
Contributor
hircos
Posts: 25
Registered: ‎11-24-2009
My Device: Blackberry Z10
My Carrier: Vodafone uk

Re: Wifi connected - but no internet

Normally when I get a limited connection to the internet it's to do with the router not the blackberry, I have a Z10 and it sometimes gives me limited if it's not connected fully. I.e if I'm connecting to a hotspot etc, have you tried to see if it's your routers firewall that's not letting you through?
Please use plain text.
Developer
vmisirlis
Posts: 741
Registered: ‎10-06-2013
My Device: Q5
My Carrier: Cosmote

Re: Wifi connected - but no internet

Try resetting your phone and router the problem will disappear :smileywink:
Please use plain text.
New Contributor
GromitJK
Posts: 5
Registered: ‎11-09-2013
My Device: Z30
My Carrier: A1

Re: Wifi connected - but no internet

I talked with my internet provider and they deactivated my router´s firewall completely - without success. Still no internet connection. They even see the Blackberry connecting to the wifi.

 

So i do have the following situation:

  • Blackberry tells me that Wifi is connected (full signal)
  • Blackberry sends notification after connection is established, that connection is limited
  • Blackberry switches to 3G (visible as 3G icon in the top statusbar) while still beeing connected to wifi
  • Router sees the Blackberry and provides an IP adress - according to my provider, everything is ok with the router
  • Router firewall deactivated (temporarly)
  • Internet connection with all other devices
  • Still no internet connection with my Blackberry

 

Any ideas what could cause the internet connection problems?

Please use plain text.
Developer
vmisirlis
Posts: 741
Registered: ‎10-06-2013
My Device: Q5
My Carrier: Cosmote

Re: Wifi connected - but no internet

Try going to settings network connections and turn off data services and then try connecting to wifi again
Please use plain text.
New Contributor
GromitJK
Posts: 5
Registered: ‎11-09-2013
My Device: Z30
My Carrier: A1

Re: Wifi connected - but no internet

No. Reseting the phone and the router didn´t change anything.

 

But now i found out something new:

If i disable the data service of my phone network provider (it´s "A1" - in Austria) the Z30 immediately switches to Wifi and the internet access works.

 

That´s a workaround, but honestly i don´t want to disable 3G everytime i enter my home´s wifi range and enable it again, when leaving.

 

Any ideas how to solve this one? Thank you very much for your help!

Please use plain text.
New Contributor
GromitJK
Posts: 5
Registered: ‎11-09-2013
My Device: Z30
My Carrier: A1

Re: Wifi connected - but no internet

Yes! This works. But do i have to disable the data Services every time i come home and enable it again when leaving my wifi range? That would be annoying.
Please use plain text.
New Contributor
GromitJK
Posts: 5
Registered: ‎11-09-2013
My Device: Z30
My Carrier: A1

Re: Wifi connected - but no internet

Finally found the solution. My Wifi signal was just weaker than the mobile network - so the phone switched to 3G. In my office, where we have a much better Wifi signal everything works fine.

 

Thank´s to all contributors for your help!

Please use plain text.