Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z30

Reply
New Contributor
ini_ben
Posts: 3
Registered: ‎03-10-2014
My Device: blackberry z10
Accepted Solution

please help am in a big mess

my z10 told me told restart the phone becos my videos where not opening after restarting it went from show ing just the blackberry name to red light then it went completely off,pleease help cos this is a friend phone whos birthday is today,and i have totaly ruined it,please help

Forums Advisor I
arthur72
Posts: 721
Registered: ‎11-01-2013
My Device: Z30, Z10 (10.2.1.3442), 9860 (7.1), Samsung S4
My Carrier: Indosat

Re: please help am in a big mess

[ Edited ]

Connect your device to OEM wall charger for 10 minutes, then remove the battery, simcard and sd card. Leave it for 10 minutes while it's still charging. Now reinsert the battery only and press the power button. See if the the device able to turn on. Several attempt might needed.

Good luck and et us know the result. 

____________________________________________________
• Click Likes to appreciate those who helps you
• If your issue solved, mark the best post in your thread as Solution
New Contributor
ini_ben
Posts: 3
Registered: ‎03-10-2014
My Device: blackberry z10

Re: please help am in a big mess

i just did exactly as you said but it didnt still come up, please is there any other thing i can do, it not up to 4 months since i bought it

Forums Advisor III
jerryg50
Posts: 1,229
Registered: ‎02-28-2009
My Device: Torch, Bold, Play Book, and Bluetooth HS-700

Re: please help am in a big mess

A proper cold restart for a Z10 is to remove the battery for about 15 seconds and then re-insert. Some tech people also recommend to also pull the SIM and SD card when removing the battery. Re-insert the cards and then the battery.

 

Do not leave external charge power when removing the battey. The charge power will generally keep the memory active and this is what you are trying to reset.

 

If the videos still do not open, it is possible the video data in memory is corrrupted. You can prove if this is fact by connecting the phone to a PC, and with the Link software transfer the videos to the PC. If they play on the PC this points to the possiblity there is an issue with the video player installed in the phone.

 

If there is a corrupt player software, you would have to reinstall the OS. Make sure the phone data is backed up. You can use the Link software to re-install the latest version of the OS.

 

 

Jerry G.
New Contributor
ini_ben
Posts: 3
Registered: ‎03-10-2014
My Device: blackberry z10

Re: please help am in a big mess

i have also tried that and its has not come up at all, i dont know if i should say the phone is dead, cos it not even showing anyy sign,is dere anything that can be done to a dead phone.

Forums Advisor I
arthur72
Posts: 721
Registered: ‎11-01-2013
My Device: Z30, Z10 (10.2.1.3442), 9860 (7.1), Samsung S4
My Carrier: Indosat

Re: please help am in a big mess

This article might help you.

 

It still fail, you may want to claim a warranty or bring it to the phone repair specialist.

 

Good luck.

____________________________________________________
• Click Likes to appreciate those who helps you
• If your issue solved, mark the best post in your thread as Solution
Contributor
anique0000
Posts: 20
Registered: ‎03-08-2014
My Device: Blackberry z30

Re: please help am in a big mess

same thing happened with my z30! i bought phone 4 hours ago and updated its software as instructed. during restart phone got dead.
what was the result of yours problem?
Contributor
anique0000
Posts: 20
Registered: ‎03-08-2014
My Device: Blackberry z30

Re: please help am in a big mess

i had the same problem!

when i claimed the warranty they said "dead" has no warranty!

is this an answer? because i bought phone 4 hours ago and updating is not a crime!