Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Desktop Software for PC

Reply
New Developer
dvdmatt
Posts: 22
Registered: ‎08-28-2008
My Device: Not Specified

Post from Blackberry Web Developer list

 

Good afternoon,

 

Mark Sohm suggested I post the probelms I was having upgrading my OS onto this list, can someone shed some light on a solution? It looks like all the Desktop software installers are running afoul of installation problems on Microsoft's newest OS updates and the currently posted workarounds are not sufficient.

 

Matt

 

 

 

 

 

 

Ok, I got the same message on 4.3 that i got trying to install 4.2:

 

Error 1904.Module C:...GW.dll failed to register. HRESULT -2147220473. Contact your support personnel.

 

A user would be frustrated enough at this point to just not run our software.

 

I found a solution at:

http://forums.crackberry.com/f2/how-fix-desktop-manager-error-1904-a-54700/

but it is not something every user would be comfortable performing on their computer.

 

With all the problems I encountered I don't see upgrading the phone's OS as a viable solution to the problem.

 

<snip> 

 

Nice, After installing the software and running through the 'patch' process I get the error:

 

DllRegisterServer in gq.dll failed.

Return code was: 0x80070005

 

This is not going well.

 

Matt

 

Please use plain text.
New Contributor
pebblechamp
Posts: 6
Registered: ‎08-30-2008
My Device: Not Specified

Re: Post from Blackberry Web Developer list

[ Edited ]

I have been having the same problem the last few days.  On my work desktop (WinXP x64) I installed the software without hitch, but on my home desktop (WinXP Pro SP3) I also keep getting the error message:

 

Error 1904.Module C:...GW.dll failed to register. HRESULT -2147220473. Contact your support personnel.

 

I am also getting the same error message for gwapi.dll, desktopsetup_pb.dll, and syncAE_pb.dll.

 

I am a very technical person so I had no qualms with trying the crackberry fix you mentioned, but it didn't work.  I was able to register all of the modules, but when I would open up Desktop Manager it would never connect to my Curve 8320 vis USB or Bluetooth.  With Bluetooth it would recognize the phone and it would even pop up a message saying that it had "detected the device".  It would ask if I wanted to connect and I would say yes and then nothing would happen.  Another 30-60 seconds later it would pop up the same message saying it detected my Blackberry and asking if I wanted to connect.  After about the tenth time of this loop I closed out the Desktop Manager.  I uninstalled the software and deleted the program folders and then logged onto the "Administrator" account (my account is also an admin acct, but I logged onto the default admin account that is labeled "Administrator" by Windows).   Upon logging into this account, I attempted to upgrade the Windows Installer 3.1, but it told me that I have a newer version and couldn't do that (WinXP SP3).  So, I registered the atl.dll and tried installing the Desktop Manager software again (I'm installing v4.6 w/ Media Manager).  Once again I got the same error messages.  So I restarted and attempted to manually register the dll's again, and I'm now getting the same error message you were:

 

DllRegisterServer in gw.dll failed.

Return code was: 0x80070005

 

I'm starting to get pretty pissed off by all of this and I'm ready to throw the **bleep** Blackberry out the window.  I love the phone and it's capabilities, but if I can't use the capabilities then it's pretty much worthless to me... then I should have just gotten an iPhone or a WinMobile device.  It makes no sense to me that the software will install just fine on my WinXP x64 machine at work and not on my 32-bit home machine.  Usually it's the 32-bit progs on the 64-bit machine that cause problems.  When is a fix going to come?  Here are my details:

 

BB Curve 8320, OS v4.5.0.52 (Platform 2.7.0.66)

WinXP Pro, Service Pack 3

Pentium 4, 2.80GHz

2GB DD400 Dual-Channel RAM

 

Message Edited by pebblechamp on 08-30-2008 01:55 PM
Please use plain text.
New Contributor
pebblechamp
Posts: 6
Registered: ‎08-30-2008
My Device: Not Specified

Re: Post from Blackberry Web Developer list

On the forum page for the Crackberry Fix someone else is having a similar problem and is also running WinXP, SP3.  It would seem that the problem is with Service Pack 3.  Will an updated installer package be released that is *gasp* actually compatible with Windows?
Please use plain text.
New Developer
dvdmatt
Posts: 22
Registered: ‎08-28-2008
My Device: Not Specified

Re: Post from Blackberry Web Developer list

Has anyone else found a solution to this problem?

 

Please use plain text.