Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
dangudnez
Posts: 2
Registered: ‎05-03-2013
My Device: Curve 8900
Accepted Solution

BIS Subscription Not Working On My BlackBerry Curve 8900

I am from Nigeria. I bought a fairly used BlackBerry® Curve 8900 from a friend recently. This is the second time I subscribed for the BIS Plan (the Carrier being MTN) but unable to make use of the service. The edge on the phone is still on 'lower case' instead of 'EDGE'. The only Applications I can make use of are the Third Party Applications. I have called the MTN Service Provider in my home country (Nigeria) time without number, to know if the problem was from them (MTN) but they confirmed my subscription to be active. I was asked to go through a Hard Reset and also register my device in the 'Host Routing Table; I have removed my battery a million times, wait for some seconds before putting it back, still there wasn't any change. Likewise registering the device in the Host Routing Table, yet no message has been received - the HRT still remain blank.
Please kindly help me through this because I don't know what next to do.

Thank You.
Hall of Famer II
sdgardne
Posts: 48,785
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.2.1531), Playbook (2.1.0.1526)

Re: BIS Subscription Not Working On My BlackBerry Curve 8900

Hi and Welcome to the Community!

 

If your voice services are working correctly (e.g., voice calling, voice mail, SMS) from MTN, then it is a matter for them to resolve...only they can look "behind the scenes" at their network to understand why your BB cannot properly communicate with their network.

 

Some possible reasons:

  • Your BB PIN is locked to another carrier BIS system, and therefore MTN cannot properly create a BIS account for it
  • Your BB PIN is reported as lost/stolen, and therefore no carrier can properly create a BIS account for it

 

Given what MTN told you, those seem unlikely...unless they really did not dig deep enough. What you should do is request that they escalate your case up to BlackBerry for enhanced support. Given what you describe, there's really nothing for you to do on the device itself.

 

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code
New Contributor
dangudnez
Posts: 2
Registered: ‎05-03-2013
My Device: Curve 8900

Re: BIS Subscription Not Working On My BlackBerry Curve 8900

Thank you very much for quick reply. I'm grateful.!
New Member
olaepals
Posts: 1
Registered: ‎09-26-2013
My Device: storm 9550

Re: BIS Subscription Not Working On My BlackBerry Curve 8900

Please I've got the same problem too, i've been using my BB for over two years with the BIS network but all of a sudden it went off to edge', whenever I move closer to the network's mass and 'register' through the 'host routing table', my BIS comes to life but once I leave the area, it goes off to edge again. please help, do i need to upgrade the OS or what? Btw Im using storm 9550 with MTN network.

Hall of Famer II
sdgardne
Posts: 48,785
Registered: ‎11-28-2008
My Device: Z30, Z10 & Q10 (10.2.2.1531), Playbook (2.1.0.1526)

Re: BIS Subscription Not Working On My BlackBerry Curve 8900


olaepals wrote:

Please I've got the same problem too, i've been using my BB for over two years with the BIS network but all of a sudden it went off to edge', whenever I move closer to the network's mass and 'register' through the 'host routing table', my BIS comes to life but once I leave the area, it goes off to edge again. please help, do i need to upgrade the OS or what? Btw Im using storm 9550 with MTN network.


Hi and Welcome to the Community!

 

Based on your description, I'd guess that there is nothing wrong with your device. Rather, your carrier has some new "dead zones" that are affecting you...and, as with the above, only they can actually answer such questions for you.

 

Good luck!


Occam's Razor nearly always applies when troubleshooting technology issues!
If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
Join our BBM Channels
BSCF General Channel
PIN: C0001B7B4   Display/Scan Bar Code
Knowledge Base Updates
PIN: C0005A9AA   Display/Scan Bar Code