Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Member
adieham
Posts: 1
Registered: ‎12-30-2012
My Device: BOLD9900

Error: invalid manifest or application descriptor

Hi, so I'm no techy but I've been trying to upgrade my appworld and everytime I try to download it on my browser I get this message: "Error: invalid manifest or application descriptor". Is there anyone that can help me without all the "jad and MIDlets" and all those other things I'm not too familiar with? Please!!!!!!
Guru I
Xandrex
Posts: 18,404
Registered: ‎07-29-2008
My Device: Z30, Playbook, 9320BES
My Carrier: B&You _ SFR

Re: Error: invalid manifest or application descriptor

my advice is to uninstall the AppWorld (using the Application Management tool in the device options), then installing it again by going to http://appworld.blackberry.com/ .



The search box on top-right of this page is your true friend, and the public Knowledge Base too:
New Member
dominiclucey1
Posts: 1
Registered: ‎05-18-2014
My Device: BlackBerry Torch 9800

Error: invalid manifest or application descriptor

[ Edited ]

Hi 

I encountered the same problem and tried to remedy it by deleteing the programme using the BlackBerry Desktop Software while my device was plugged in, after I applied the update to my device, it changed the files and rebooted the phone.

I then installed it using the same desktop software but it still didn't work.

Do you understand why? 

Also if I uninstall the programme using the application manager on the phone will I be able to re-install it using the desktop manager?

I am using Giff Gaff as my service provider.

I look forward to hearing from you.

Dominic