Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

Reply
New Contributor
tsrg23
Posts: 6
Registered: ‎09-04-2012
My Device: Curve 9300

BlackBerry Internet Service issues

For the past 24 hours, I've been having problems opening up online games that require BIS to work. Whenever I attempt to load these games, my phone freezes until an error message appears a couple of minutes later (these either say 'failed to transit', or 'local connection timed out ~ 120000').

However, not all apps that require BIS to run are affected. I can still access the Facebook for BlackBerry app, BlackBerry Messenger and BlackBerry App World. The issue only lies with four particular games.

I renewed my monthly subscription to BIS a few days ago, and before today these apps were working fine. I've never had problems like this before; BIS has always been a bit temperamental (the BlackBerry logo that accompanies '3G' to indicate that I'm connected to BIS disappears every now and again), but it always came back on within a matter of minutes, or sometimes seconds.

I tried heading to 'manage connections' and turning my connection to the network off and on again, and also heading to 'advanced settings' to register my device on the wireless network again (my usual two solutions), but it has been futile. Then I tried running the diagnostic program, but it didn't help as sometimes it would show that I was connected to BlackBerry, and on other occasions I'd just get a 'no' next to it. I've also tried pulling the battery out, replacing it and rebooting the phone, as that tends to work as a last resort. This time though, well...'wishful thinking' comes to mind.

Three of the four games in question are made by the same company, and these are the ones that I play most frequently. This led me to believe that it may be a company-specific problem. The fourth one however is made by a completely different developer, so I've come to the conclusion that this must be a network- or device-specific problem. The first three apps I mentioned were all downloaded from BlackBerry App World, but the fourth was downloaded from the developer's website. All four apps share the same problem though; I simply cannot play them, because my phone won't connect to BIS during this time.

If anyone could shed some light on possible causes - or better still, offer a solution - I would be most grateful.

Kind regards,
tsrg23.

(BlackBerry Curve 9300 user)
(Carrier - Vodafone UK)
Guru I
John_Clark
Posts: 16,158
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1154; PlayBook w/OS 2.1.0.1917

Re: BlackBerry Internet Service issues

I would check with your carrier, Vodafone. Also, keep in mind that Facebook and AppWorld do not require BIS anymore so that's not a real good test. BBM, however, does require BIS but each carrier has different data plans that can allow BBM but not other apps. I would check with your carrier.

John
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
New Contributor
tsrg23
Posts: 6
Registered: ‎09-04-2012
My Device: Curve 9300

Re: BlackBerry Internet Service issues

Thanks for the reply John.

That's strange, because I'm not able to use Facebook or App World unless I have a subscription to BIS (I always test the apps out once I've suscribed back to BIS, and until my phone has been rebooted they refuse to work). What do Facebook and App World require to run now?

Like I mentioned previously, I have a recently renewed subscription to BIS which is required to play these games, and I haven't ever had any problems like these before, so it's a little frustrating.

Thanks again for the reply; I'll get on the phone to Vodafone now.

Cheers,
tsrg23.
Guru I
John_Clark
Posts: 16,158
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1154; PlayBook w/OS 2.1.0.1917

Re: BlackBerry Internet Service issues

A wifi connection is all that's required. Also, I think that a regular carrier data plan will work too. You have to be running the latest versions of the apps, though.
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
New Contributor
tsrg23
Posts: 6
Registered: ‎09-04-2012
My Device: Curve 9300

Re: BlackBerry Internet Service issues

I don't have broadband at home, so I can't connect to wi-fi. That's why I suscribe to BIS each month; so I can use BBM, App World, Facebook and those games.

All of the apps in question are up to date too. It's either a device or network issue, because three of the games are made by the same developer, and the fourth is from a completely different company. They all stopped working at the same time though.

Plus my Facebook for BlackBerry app has now completely stopped working, and now whenever I run the diagnostic program, it says 'BlackBerry Registration: Yes. Connected to BlackBerry: No'. Yesterday my phone would 'connect to BlackBerry', but still none of the apps (except for Facebook) were working...
Guru I
John_Clark
Posts: 16,158
Registered: ‎04-01-2008
My Device: BlackBerry Z30, Z10 and Q10 w/OS 10.3.0.1154; PlayBook w/OS 2.1.0.1917

Re: BlackBerry Internet Service issues

It sounds like a network problem, then. I would try the following:

Go to Options and type in "Host Routing Table" in the search bar. Click on Host Routing Table. In that list, hit the menu key and select "Register Now." That should push the proper service books to your device.

If that doesn't work I would contact Vodafone as it's possible they put you on the wrong data plan.

John
--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!