Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
tonybse
Posts: 61
Registered: ‎09-29-2008
My Device: Not Specified
Accepted Solution

907 invalid cod error during OTA

Hello,

I have a problem with OTA download on
v4.1.0.268 (platform 2.2.0.112).  bb 7250 on cdma network.
It says 907 invalid cod error

the jad/jar/cod are created with JDE 4.6

However, I can do OTA using BB 9000 emulator with the same files / same download url.


I followed the diagnostic mentioned in
http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800708/800646/Support...

all sizes are correct in the jad file. Should I so something specific for older BB devices when I deploy the apps for OTA?


here is the jad :

Manifest-Version: 1.0
RIM-COD-Module-Name: TestSpeed
RIM-COD-Module-Dependencies: net_rim_cldc
MIDlet-Jar-Size: 30100
MIDlet-1: ,,
RIM-COD-Creation-Time: 1224023296
MIDlet-Jar-URL: TestSpeed.jar
RIM-COD-URL: TestSpeed.cod
RIM-COD-SHA1: 05 3b ef a7 31 21 a5 9d 3c 4c 6c ed 6d e0 a6 3f bf 1b d3 a8
RIM-COD-Size: 26200
MicroEdition-Configuration: CLDC-1.1
MIDlet-Version: 0.0
MIDlet-Name: TestSpeed
MIDlet-Vendor: <unknown>
MicroEdition-Profile: MIDP-2.0
RIM-MIDlet-Flags-1: 0

Developer
tonybse
Posts: 61
Registered: ‎09-29-2008
My Device: Not Specified

Re: 907 invalid cod error during OTA

In addition, I can reproduce the situation with emulators only.

Using BB 9000 emulator from JDE 4.6 - OTA is OK and app can start after that

Using BB 8100  emulator (4.2.0.71) - OTA can not be done, stated 907 invald COD error

 

 

New Developer
lanceo
Posts: 22
Registered: ‎07-17-2008
My Device: Not Specified

Re: 907 invalid cod error during OTA

You shouldn't use a JDE higher than the OS of the device you are deploying to.  If you are supporting 4.1 devices, you should use the 4.1 JDE for your build.    Devices are backward compatable, not compilers.
Developer
tonybse
Posts: 61
Registered: ‎09-29-2008
My Device: Not Specified

Re: 907 invalid cod error during OTA

Thanks, but I am not using anything which is BB specific, no rim classes at all. Should I still use the older JDE only? How about other IDEs? (Netbeans, Eclipse,...?)
BlackBerry Development Advisor
MSohm
Posts: 14,757
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: 907 invalid cod error during OTA

It doesn't matter which APIs are used (the format of the cod file itself has changed along the way).  Please see the following link.

 

What Is - Appropriate version of the BlackBerry JDE
Article Number: DB-00537

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800901/What_Is_-_Appr...

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker