Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 1,474
Registered: ‎04-14-2009

Re: API 5.0: RIMAPPSA2 signing required for app that doesn't use signed classes

According to the attached log, SetionMetrics without FontMetrics no longer has issues with verification/linking errors. It starts, but then fails because an UnsupportedOperationException is thrown (OpenGL not supported).

Please use plain text.
Administrator
MSohm
Posts: 14,065
Registered: ‎07-09-2008
My Carrier: Bell

Re: API 5.0: RIMAPPSA2 signing required for app that doesn't use signed classes

FontMetrics is not a public class, which means it can not be used by a third party application.  You should only make use of classes listed in the BlackBerry API Documentation.

 

The BlackBerry Storm 9530 does not support OpenGL ES.  Currently, only the BlackBerry Storm 2 9550 has support for it.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Carrier: Verizon

Re: API 5.0: RIMAPPSA2 signing required for app that doesn't use signed classes

Ok, thanks for responding.

 

It's disappointing that OpenGL ES is not supported on the 9530 but it introduces some questions such as the program won't run unless GLUtils.isSupported returns true. It returns true on my 9530 and on the 9500/9530 simulator, that is why I was able to run the app on the device. May I ask why the 9530 (which from what I read has the same CPU/GPU combo as the 9550) does not support OpenGL ES?

 

Second, I don't know if the Eclipse BlackBerry plugin 1.1 Beta has an older documentation version then the online documentation but it lists FontMetrics as a public class. I now know ot to use it and will remove it to prevent problems from the other apps that currently have it as a place holder.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
Posts: 1,474
Registered: ‎04-14-2009

Re: API 5.0: RIMAPPSA2 signing required for app that doesn't use signed classes

FontMetrics is also listed as public API in the javadocs of a JDE v5.0.0 beta that I have (I don't have access to the build/bundle number right now)...

Please use plain text.
Administrator
MSohm
Posts: 14,065
Registered: ‎07-09-2008
My Carrier: Bell

Re: API 5.0: RIMAPPSA2 signing required for app that doesn't use signed classes

There are other hardware limitations that prevent the use of OpenGL ES on the BlackBerry Storm 1.

 

GLUtils.isSupported should return false on this device.  I have sent that issue to our development team.

 

FontMetrics is not listed in the API documentation in the current beta 5 release of the 5.0 BlackBerry Java SDK plug-in for Eclipse.  It may have been accidentally included in a previous beta.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
Posts: 1,474
Registered: ‎04-14-2009

Re: API 5.0: RIMAPPSA2 signing required for app that doesn't use signed classes

Thanks for a very prompt and clear reply, Mark!

Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Carrier: Verizon

Re: API 5.0: RIMAPPSA2 signing required for app that doesn't use signed classes

Thanks for the response. I am a little disappointed that OpenGL is not supported but it gives me an incentive to get the Storm 2.

 

As for the GLUtils.isSupported I just checked and something must have changed since the last time I used it because previously it returned true, now it returns false. Sorry for the mistake.

 

As for the Eclipse plugin, was a new version released since the initial release after the BlackBerry Developer Conference? If so then I need to update.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Carrier: Verizon

Re: API 5.0: RIMAPPSA2 signing required for app that doesn't use signed classes

Nevermind about the Eclipse question, I just checked the Update Site and found that updates were avalible.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.