Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Regular Contributor
heretocode
Posts: 70
Registered: ‎12-19-2011
My Device: Bold 9780
My Carrier: Airtel

App is working on wifi but not on sim

Hi all

 

My app is working fine on wifi network.But on sim network it doesn't run.What setting should  i change.

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: App is working on wifi but not on sim

What does "doesn't run" in the following sentence mean?

"But on sim network it doesn't run"

 

Does it mean:

- Doesn't start?

- Walks? (goes slowly)?

- Fails with an exception?

 

I am suspcting you have a network problem, in that it fails to get data from the Server.  If so, I suspect you have a bit of reding to do.  Start by typing "network" in the Search box and review the Networking videos you will find.  Then have a look at this:

http://supportforums.blackberry.com/t5/Java-Development/Different-ways-to-make-an-HTTP-or-socket-con...

 

Finally you are quite liekly to have an issue with the Event Thread.  if you haven't thougfht about this and your networking is not running in a separate Thread, then now is the time to research the Event thread.  Type Event Thread in the Search box read the interesting stuff you find, including this:

http://supportforums.blackberry.com/t5/Java-Development/What-is-the-Event-Thread/ta-p/446865

 

Good luck

 

Please use plain text.
Developer
Kiran_Snist
Posts: 174
Registered: ‎01-25-2011
My Device: Not Specified

Re: App is working on wifi but not on sim

May u have something to do with transportInfo that is set in the server connection file!!
Please use plain text.
Regular Contributor
heretocode
Posts: 70
Registered: ‎12-19-2011
My Device: Bold 9780
My Carrier: Airtel

Re: App is working on wifi but not on sim

@ Kiran yes

as we send interface="wifi" for wifi

and ";deviceside=true"

what should i send when bis is activated.

 

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: App is working on wifi but not on sim

There is no straigthforward answer to that.

 

If you change to using ConnectionFactory, then you can set the acceptable transports.  if you stick with coding connection suffixes yourself, then you are goig to have check and chooose the correct one.  Either way, i recommend that you review the KB articles and videos I pointed you at.

 

You can try to take shortcuts here but unless you spend the time learning about networking on the BB, you will continue to have problems.

Please use plain text.