Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
rifluxyss
Posts: 4
Registered: ‎11-24-2008
My Device: Not Specified

Application for BlackBerry Storm

Hello there,

 

I have an application developed using BlackBerry JDE4.0.2 and it works fine in all BlackBerry devices.

Now i have plan to do make this compatible for BlackBerry Storm.

Please let me know, if it's possible for me to make my current Java code to be compatible for Storm.

If it's not the possible, please advice me on how to start developing applications for BlackBerry storm.

 

Many thanks in advance.

 

 

Please use plain text.
Developer
RexDoug
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Application for BlackBerry Storm

Download the JDE 4.7 beta from the developers site. It has a Storm simulator bundled in.

 

Most apps will "run" without modifications, but you will have to address usability issues (like: things are too small to touch, etc).

 

 

Please use plain text.
Developer
davidmccormack
Posts: 168
Registered: ‎11-01-2008
My Device: Galaxy S II
My Carrier: Meteor (Ireland)

Re: Application for BlackBerry Storm

Or, do what I did and just download the Storm simulator on its own if you don't want to risk messing up your older JDE.
Please use plain text.
New Developer
rifluxyss
Posts: 4
Registered: ‎11-24-2008
My Device: Not Specified

Re: Application for BlackBerry Storm

Many thanks for your response.

I will try to open my project using JDE 4.7 and let you know, if it's working fine.

Please use plain text.
New Developer
rifluxyss
Posts: 4
Registered: ‎11-24-2008
My Device: Not Specified

Re: Application for BlackBerry Storm

Hi davidmccormack,

I have tried to load COD file of my application into Storm simulator, but it does not respond.

So now i am downloading JDE4.7.

Why does my COD not loading into Storm simulator?

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: Application for BlackBerry Storm

I don't know any general reason why a 4.0.2 cod would not start in the Storm.  What do you mean by "does not respond"?
Please use plain text.
New Developer
rifluxyss
Posts: 4
Registered: ‎11-24-2008
My Device: Not Specified

Re: Application for BlackBerry Storm

Suppose when i load COD into 7520 simulator, there will be a hour-glass icon to show the application being loaded.

But it's not the case with Storm simulator.

Please use plain text.
Developer
davidmccormack
Posts: 168
Registered: ‎11-01-2008
My Device: Galaxy S II
My Carrier: Meteor (Ireland)

Re: Application for BlackBerry Storm

When I load into my Storm simulator it completes almost instantly with no hourglass. Are you remembering to look in the downloads folder?
Please use plain text.
New Developer
daneast
Posts: 3
Registered: ‎11-24-2008
My Device: Not Specified

Re: Application for BlackBerry Storm

I am facing a similar scenerio - I have an existing application (4.3.0) that I need to tweak for the Storm.  My application does run fine in the simulator, and I was able to add a simple "hack" to check for changes of device orientation (by comparing the screen dimensions from the last paint to the dimensions from the current paint).

 

However I need to respond to the touchscreen.  I can already detect the "click" event.  Now I need to know the X, Y coordinate of the event, as well as detect "touch" events.

 

Is it possible to receive those notifications through the older APIs?  If not, if I build an application under 4.7.0 is it backwards compatible?  If I use APIs specific to the Storm related to the touchscreen can my application still run on older devices?

 

Thanks!

Please use plain text.
Administrator
MSohm
Posts: 14,376
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Application for BlackBerry Storm

In order to use the new touch screen APIs, you'll need to build the application with the version 4.7.0 (or higher) BlackBerry JDE.  Applications built in the version 4.7.0 BlackBerry JDE would require BlackBerry handheld software version 4.7.0 or higher.

 

What Is - Appropriate version of the BlackBerry JDE
Article Number: DB-00537

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800901/What_Is_-_Appr...

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.