Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Regular Contributor
hitesh171285
Posts: 95
Registered: ‎07-16-2010
My Device: 8520
Accepted Solution

Application not work with os5

Starting MYApp
Class 'net.rim.device.api.ui.component.PasswordEditField' not found.
Error starting MYApp: Class 'net.rim.device.api.ui.component.PasswordEditField' not found.

 

Issue :- Application gives error on click on app icon


test := os 7 working fine , problem when i debug , run and even with device

 

with OS 6 :
 

Class 'net.rim.device.api.ui.ScrollView' not found.
Error starting MYApp: Class 'net.rim.device.api.ui.ScrollView' not found.

 

 

for that :- i re install java , blackberry eclips plugin

              : - when i make new app with simple test screen its working also with password field other application also work

             : at build and packaging time no issue in any os

 

and also i make new project and import source then run  but same issue

 

help me please

Please use plain text.
Developer
simon_hain
Posts: 16,207
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: Application not work with os5

compile the application with the JRE similar or lower to your target OS.
In this case with JRE 5.

ScrollView is since 6.0 and won't be available, you could use preprocessing to avoid it.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Regular Contributor
hitesh171285
Posts: 95
Registered: ‎07-16-2010
My Device: 8520

Re: Application not work with os5

thanks for replay simon

 

i do that bit not work

Please use plain text.
Regular Contributor
hitesh171285
Posts: 95
Registered: ‎07-16-2010
My Device: 8520

Re: Application not work with os5

got the issue its cause 6mb of build size

 

its sucking blackberry error report

when i my app size is 6 mb its give error like

 

not found password field

after i remove password field its give erron listfield not found

 

and yes when i put 20 mb data in app source that time app is build but at run time its not install in simmulater / device

 

--------------------------Blackberry devloper may be understand that ------------------

 

any way thanks for replay simon

Please use plain text.