Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
taovu
Posts: 6
Registered: ‎09-05-2008
My Device: Not Specified

Application verification error

Help... Please

 

I got an BB application with cod file about 143K and jar file about 385K. The application is running fine on 8800 and 8700 simulators and device, but it always returns "Moduler xxx has verification error" when running on 9000 simator/device.

Following is the app. Jad file:

 

Manifest-Version: 1.0

MIDlet-Version: 1.1.50

MIDlet-Jar-Size: 393623

RIM-COD-URL-2: MJSCEval-2.cod

MicroEdition-Configuration: CLDC-1.1

MIDlet-Jar-URL: MJSCEval.jar

RIM-COD-Module-Dependencies: net_rim_cldc

RIM-COD-SHA1-2: d9 88 1d ee b6 44 8b 7b 23 90 35 be 1d 25 76 2f be 16 8d 58

RIM-COD-URL-1: MJSCEval-1.cod

RIM-COD-SHA1-1: ca b9 1f 5b 6e d2 13 7c 63 9a 36 4c 4d 40 2b 95 f7 b0 48 9e

RIM-COD-Size-2: 28512

RIM-MIDlet-Flags-1: 0

RIM-COD-Size-1: 48048

RIM-COD-Module-Name: MJSCEval

MIDlet-Name: MJSCEval

RIM-COD-Size: 68592

RIM-COD-Creation-Time: 1229538580

MIDlet-1: Mobile Job Schedular,,

RIM-COD-URL: MJSCEval.cod

MIDlet-Description:Job Schedule Calendar

RIM-COD-SHA1: 15 a0 85 f8 90 60 ab c8 98 0c a7 3c b1 21 9d f8 3f eb 44 54

MicroEdition-Profile: MIDP-2.0

MIDlet-Vendor:JSCM

 

Since our app. is big and the cod file is sibled in to 3 cod files. Will it will generate the verification error? I also built and can run a small application in "same enviroment", it's OK.

Would you please help me how to overcome this issue. I already tried to unzip the Cod files , load them seperately, and run the app. on both IDE version 4.1.1 and 4.6.0 but I still got verification error.

 

Please help!!!!!

 

Thanks

Taovu

BlackBerry Development Advisor
MSohm
Posts: 14,757
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: Application verification error

Have you created a MIDlet or BlackBerry CLDC application?  If you build the application in the version 4.6.0/4.7.0 BlackBerry JDE does it work on the BlackBerry Bold (4.6.0)/BlackBerry Storm (4.7.0).  Does the issue only occur if the application is built in a lower version of the BlackBerry JDE?  Have the cod files been created in the BlackBerry JDE from source Java files or are you converting a JAR file built in another IDE?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
taovu
Posts: 6
Registered: ‎09-05-2008
My Device: Not Specified

Re: Application verification error

Thank you for your response. Our application is BB CLDC app and its cod/jar files are built form BB JDE. I tried to build our app. on 4.6.0, 4.6.1 and 4.7.0 BB JDE, i got the same problem event with the Bold and Storm simulators.
BlackBerry Development Advisor
MSohm
Posts: 14,757
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: Application verification error

Do you have any large images or resource files within your application?  If so, can you try removing them?  Do you have a public link to download the application that I could use for testing?
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
taovu
Posts: 6
Registered: ‎09-05-2008
My Device: Not Specified

Re: Application verification error

Our app has about 15 png images (1-2K each) and 5K-rrc/3K-rrh.  

You can OTA ior app at

http://powerviewmobile.bjservices.com:8088/MJSC.jad  

 

When I compile and run on  BB JDE  4.7.0/ 9500 Simulator. I got

“Error starting MJSCEval: Module 'MJSCEval' has verification error 3153”.

When  I compile and run  on BB JDE 4.6.1 and 8900 simulator or my BB bold, I got

“Error starting MJSCEval: Module 'MJSCEval' has verification error 3141”

 

Please help

Thanks

TaoVu

 

 

BlackBerry Development Advisor
MSohm
Posts: 14,757
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: Application verification error

Can you try removing the PNG images?  I have seen where some PNG images can trigger this error. Touching them with and image editor and saving/reencoding the image can resolve the issue.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
taovu
Posts: 6
Registered: ‎09-05-2008
My Device: Not Specified

Re: Application verification error

I removed all png files, recompile under BB JDE 4.6.0.12 and 9000 (2.10.0.78) I got "Verification error 3141". When I tested under BB JDE 4.7.0.41/9500 Simulator (2.11.0.86), I got "Verification error 3153". But the app is loaded and displayed the login page (without image) OK with 8800 Simulator 2.9.0.56

 

Please advice

TaoVu

BlackBerry Development Advisor
MSohm
Posts: 14,757
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: Application verification error

Please send a copy of this application to devsupport@rim.com.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
ronaldg
Posts: 18
Registered: ‎10-30-2008
My Device: Not Specified

Re: Application verification error

I have the same error but this is very strange. I have been working and had no problems with my app. I changes a bit of code and all of a sudden all I get is Module Xyz has varification error 3141.

 

I tried removing the .png . I then tried going back to 4.6. I currently am working in 4.7 on a bold 9000.

 

It worked for 50 compiles and then all of a sudden it stopped working.

 

Any idea?

Thanks

Ron 

Developer
ronaldg
Posts: 18
Registered: ‎10-30-2008
My Device: Not Specified

Re: Application verification error

By the way CLDC application and it has been since I added something to the code but I don't know what.

I went back one verison of my code and compiled it with 4.7 and it works fine. Now I have to figure out what caused the problem.

I hope someone can help me because I'm in a real bind.

Thanks