Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
bb_dev
Posts: 11
Registered: ‎10-12-2008
My Device: Not Specified

Re: Audio completely dead after recording and play back for a while

Thanks for the info Mark
New Developer
sunilpalacherla
Posts: 1
Registered: ‎02-06-2009
My Device: Not Specified

Re: Audio completely dead after recording and play back for a while

I am new to blackberry development. Been trying to record and playback audio in PCM format with the simulator. After several failed attempts to write my own code to do just that, I realized I will pick a well known example and try with PCM record and playback. I picked the same example on this page and changed

 

- encoding=pcm

- file extension to .wav

 

Environment

- JDE 4.6

- 9000 simulator

 

Can I playback a PCM encoded file on 9000 simulator? 

If I can, can someone point me to tips/tricks/code please?

 

Thanks.

 

BlackBerry Development Advisor
MSohm
Posts: 14,753
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: Audio completely dead after recording and play back for a while

The BlackBerry Simulator uses the audio codecs on your PC for media playback, so this can vary based on your PC configuration.  The following link lists what is supported on real BlackBerry handhelds.

 

http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB05482&sliceId=1&docTy...

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
pgaylie
Posts: 1
Registered: ‎07-08-2009
My Device: Not Specified

Re: Audio completely dead after recording and play back for a while

I have customers that are expierencing the same problem (dead audio).  I was able to compile the code in this thread and reproduce the error. The device is an 8310 with software version 4.5.0.81.

 

Is there a firmware fix for this problem?

 

 

Developer
Developer
thm
Posts: 21
Registered: ‎09-12-2009
My Device: Not Specified

Re: Audio completely dead after recording and play back for a while

[ Edited ]

I am having the same problem on an 8320 4.5.0.124.. when switching from playing to recording a few times the audio will completely fail, the above program also reproduces the error.. is there any sign of a resolution to this problem? I have not been able to create a work around and this is also a showstopper for our application

Developer
jack_black
Posts: 74
Registered: ‎01-03-2010
My Device: Not Specified

Re: Audio completely dead after recording and play back for a while

in 4.5 component pack and some 87xx series simulators (also 83xx) surely has problem with playback

 which is not general threading related issue but purely unsupported format bug in simulators.