Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Iyenemi_Tyger
Posts: 132
Registered: ‎10-25-2011
My Device: Tour 9630
Accepted Solution

Autostart up application library issue

Hello and good day ,

Please i have a blackberry application and then an application library project(auto-run on start up) , i have configured the library project to work with the main project such as build and export configurations , it works fine on the simulator but when i load it on the device i seem to get issues , its say module not found .its not an ota installation though , it is the ide load on device option i have used so far , thanks.

Please use plain text.
Developer
simon_hain
Posts: 16,190
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: Autostart up application library issue

how do you load the library onto the device?
is it marked as export in the build options? or loaded as a separate cod?
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
Iyenemi_Tyger
Posts: 132
Registered: ‎10-25-2011
My Device: Tour 9630

Re: Autostart up application library issue

I am using eclipse 1.3 for bb , and the option is in java build path I selected my carnirv library and then under order and export I place I select the app library , I build the project and then I right click and select load project on device , it workls well on simulator though.
Please use plain text.
Developer
Iyenemi_Tyger
Posts: 132
Registered: ‎10-25-2011
My Device: Tour 9630

Re: Autostart up application library issue

i got it solved , what i did was configure tehe rim cod size and rim code url options of the jad file to pint to the properties of the application library .cod file , thanks .

Please use plain text.