Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
sarnab2
Posts: 8
Registered: ‎08-09-2011
My Device: montana
My Carrier: verizon

BBM SDK testing problems on simulator using ECLIPSE plugin

Hi,

 

I have downloaded the "BBM SDK v1.3 for BlackBerry Java" , in the Installation guide it is  mentioned 

  1. In the folder where you extracted the BlackBerry Messenger SDK file, open the BlackBerry smartphone simulator folder.
  2. Double-click the BlackBerry_Simulators_<version>_<model>.exe file.

But the "BBM SDK v1.3 for BlackBerry Java.zip DOES NOT have any such folder (BlackBerry smartphone simulator) within all the subfolders, so I installed the simulator from "http://us.blackberry.com/developers/blackberrymessenger/" and using eclipse changed the Run configuration for the simulator.

 

The problem is I could not create the "sim1.bat and sim2.bat" as written in the guide, and ECLIPSE DOES NOT allow multiple simulators to run with the SAME App.

 

I tried launching another simulator from the installed simulator, but I see JAVA ERROR 104 on both the simulators as soon as I launch the app.

 

P.S. I tried setting the BBSDKSample App on both the simulators.

 

Please help me with this.

 

Thanks,

Sarnab

Please use plain text.
New Contributor
sarnab2
Posts: 8
Registered: ‎08-09-2011
My Device: montana
My Carrier: verizon

Re: BBM SDK testing problems on simulator using ECLIPSE plugin

Does any one know anything about a fix for this?

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: BBM SDK testing problems on simulator using ECLIPSE plugin

BBM enabled Simulators can be downloaded from this page:

http://us.blackberry.com/developers/blackberrymessenger/

Please use plain text.
Developer
arindamhit
Posts: 271
Registered: ‎12-24-2010
My Device: BlackBerry 10
My Carrier: Airtel

Re: BBM SDK testing problems on simulator using ECLIPSE plugin

I worked with BBM SDK 1.2. When you unzip the BBM SDK v1.2 for BlackBerry Java you will get 5 folders.

1. BBM SDK 1.2

2. MDS Simulator

3 BlackBerry Smartphone Simulator

4. Java Docs

5. sample Apps.

 

I think for BBM SDK 1.3 is also you should get the same folders. What are the folders you are getting?? Can you please tell.

Please use plain text.
New Contributor
sarnab2
Posts: 8
Registered: ‎08-09-2011
My Device: montana
My Carrier: verizon

Re: BBM SDK testing problems on simulator using ECLIPSE plugin

Yes, I know, I downloaded it from the same location, but How do I create sim1.bat and sim2.bat? and since Eclipse doesnt allow more than 1 simulator to run, can you please tell me what is the workaround ?

 

Regards,

Sarnab

Please use plain text.
New Contributor
sarnab2
Posts: 8
Registered: ‎08-09-2011
My Device: montana
My Carrier: verizon

Re: BBM SDK testing problems on simulator using ECLIPSE plugin

Thanks Arindam for the reply.

 

The folders are

 

BBM SDK 1.3

Java Docs

MDS Simulator

Sample Apps

 

The folder "Blackberry Smartphone Simulator" isnt present.

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: BBM SDK testing problems on simulator using ECLIPSE plugin

Have you looked at the link I supplied?  Just download them directly from that page. 

Please use plain text.
Developer
arindamhit
Posts: 271
Registered: ‎12-24-2010
My Device: BlackBerry 10
My Carrier: Airtel

Re: BBM SDK testing problems on simulator using ECLIPSE plugin

But it should present. Download once again and try. Otherwise go with BBM 1.2

Please use plain text.
Developer
peter_strange
Posts: 19,601
Registered: ‎07-14-2008
My Device: Not Specified

Re: BBM SDK testing problems on simulator using ECLIPSE plugin

In my opinion, don't do either of the above options, just download the SImulators.

 

The BBM 1.3 download I have, does not include the SImulators so there is no point trying to download 1.3 again.  And why go back to 1.2 just for the SImulators when you can download them?

 

We can report this as a problem to RIM.  Either the documentation needs to be updated or the Simulators need to be included. 

 

For me, the SImulators don't need to be included because they are available via an alternative method.  And I think the alternative method is better because it provides RIM with an easy way to add extra Simulators. 

 

So just download the SImulators you want to use.

Please use plain text.
New Contributor
hoshurik
Posts: 6
Registered: ‎01-24-2012
My Device: 9700
My Carrier: MTS

Re: BBM SDK testing problems on simulator using ECLIPSE plugin

Can someone share an older version of bbm sdk (1.0 or 1.2), please?

I'm looking for it because v1.3 is compatible with BB Messenger 6.1 or newer only.

Please use plain text.