Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
nikita18
Posts: 144
Registered: ‎08-18-2012
My Device: Blackberry Curve 8520

BBM not launching programmatically

I was using the following code to launch BBM programmatically:

 

try {
ApplicationManager.getApplicationManager().launchApplication("net_rim_bb_qm_peer");
} catch (ApplicationManagerException e) {
// TODO Auto-generated catch block
e.printStackTrace();
}

 its working with the simulator but its not working with my device. Can anyone point me where I'm wrong.

Thanks a lot. 

Please use plain text.
Developer
peter_strange
Posts: 19,607
Registered: ‎07-14-2008
My Device: Not Specified

Re: BBM not launching programmatically

Sorry need to start simple here:

 

What OS's are involved on Simulator and device.?

 

What level of BBM is on Simulator?

 

Does this throw an exception on the device?

 

What level of BBM is on device?

Please use plain text.
Developer
nikita18
Posts: 144
Registered: ‎08-18-2012
My Device: Blackberry Curve 8520

In my Simulator

My simuator has 7.1 OS and device has 5.0 OS. Its not throwing exception on simulator. I don't know about the device.

Please use plain text.
Developer
peter_strange
Posts: 19,607
Registered: ‎07-14-2008
My Device: Not Specified

Re: In my Simulator

Can you answer my other questions too?

 

This might help for the problem on device:

http://supportforums.blackberry.com/t5/Java-Development/How-Do-I-Debug-on-a-Live-Device/ta-p/446842

 

Also have you read the information under this Heading:

Installing additional BlackBerry SDK versions

on this page:

https://developer.blackberry.com/java/download/eclipse/

Please use plain text.
Developer
nikita18
Posts: 144
Registered: ‎08-18-2012
My Device: Blackberry Curve 8520

Re: In my Simulator

CAn you please tell how I can get the level of BBM? 

Please use plain text.
Developer
peter_strange
Posts: 19,607
Registered: ‎07-14-2008
My Device: Not Specified

Re: In my Simulator

Options-->Device-->Application Management

BBM will be included in the list.

Slightly different for OS 5.0 and earlier, but you should be able to figure it out. 

Please use plain text.
Developer
nikita18
Posts: 144
Registered: ‎08-18-2012
My Device: Blackberry Curve 8520

Re: BBM not launching programmatically

My BBM version in device is 6.2.0.44. I'm not able to find BBM version in the simulator because its showing only "Personalisation and Privacy for search" in the options -> third party applications. 

Please use plain text.
Developer
peter_strange
Posts: 19,607
Registered: ‎07-14-2008
My Device: Not Specified

Re: BBM not launching programmatically

For OS 5.0 and earlier to find Applications, you use:

 

Options-->Advanced-->Applications.

 

I am pretty confident you have a version mismatch.  Not sure if it is BBM or OS. 

 

And can you confirm that you have you read the information under this Heading:

Installing additional BlackBerry SDK versions

on this page:

https://developer.blackberry.com/java/download/eclipse/

 

The information there is also true for BBM Versions. 

Please use plain text.
Developer
nikita18
Posts: 144
Registered: ‎08-18-2012
My Device: Blackberry Curve 8520

Re: BBM not launching programmatically

Sorry for replying late Peter. Yes I have read the information you are taking about. But I'm never able to install addtional SDK versions because I everytime get link failures on those sites. 

So what do you think I should do now? 

Please use plain text.
Developer
peter_strange
Posts: 19,607
Registered: ‎07-14-2008
My Device: Not Specified

Re: BBM not launching programmatically

[ Edited ]

The first issue to resolve is to get you developing using JRE 5.0 for your 5.0 device. 

 

The instructions for updating this to give Eclipse another environment are found on this page:

https://developer.blackberry.com/java/download/#eclipse

 

Look for the heading:

How to install additional BlackBerry SDK versions

and click on it. 

 

If that does not help, then look at the heading:

Use Eclipse to install the BlackBerry Java Plug-in.

and click on it. 

 

 

Please use plain text.