Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Regular Visitor
codeblock
Posts: 1
Registered: ‎04-06-2010
My Device: Bold 9700

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

Can someone download and upload to somewhere that i can download easier than blackberry.com? (mediafire or rs)

Blackberry.com does not support resume and i can't download from there, always get timeout and cannot resume.


Thanks,

Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

[ Edited ]

Hi dkonigs,

 

RE: Library build errors:


C:\Eclipse\plugins\net.rim.ejde.componentpack4.6.0_4.6.0.23\components\lib\net_rim_api.jar(net_rim_bb_addressbook.cod): Error!: Duplicate definition for 'net.rim.device.apps.api.addressbook.AddressBook' found in: C:\Eclipse\plugins\net.rim.ejde.componentpack4.5.0_4.5.0.28\components\lib\net_rim_api.jar(net_rim_bb_addressbook.cod)

 


I just tested and reproduced this issue and will bring it up to development. In the meantime I have found that if all projects use the same BlackBerry Java SDK to build the issue goes away so this is a potential workaround.

 

 

Regards,

Garett
@garettBeuk
--
Goodbye everybody!
New Contributor
adiaz_caixa
Posts: 5
Registered: ‎12-03-2010
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

I have an eclipse 3.6 with Widget SDK 1.5 and Web Plug-in 2.5 and can't find the way to install the Java Plug-in 1.3 on it.

 

In the blackberry Update Manager I have only the SDK for 5.0, 47, 4.6... but not the Plug-in.

 

Does I need two eclipse 3.6 installations running on the same machine to develop Widget Extensions (java) and Widgets applications?

 

Thanks in advance.

Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

Currently the BlackBerry Java Plug-in for Eclipse (actual Plug-in) is only available in the stand-alone installer which also includes a full version of Eclipse:

https://www.blackberry.com/Downloads/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA5&dl=...

 

This includes Eclipse, the BlackBerry Java Development Plug-in 1.3.0 and the 6.0 SDK. Additional SDKs can be downloaded using the update site.

 

After this is installed you can use the update site for the BlackBerry Web Plug-in for Eclipse 2.5 to install the Web Development tools to this Eclipse instance to keep only 1 Eclipse install for both development environments.

 

Regards,

Garett
@garettBeuk
--
Goodbye everybody!
New Developer
aaargh
Posts: 28
Registered: ‎01-05-2009
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

 


gbeukeboom wrote:

 

This includes Eclipse, the BlackBerry Java Development Plug-in 1.3.0 and the 6.0 SDK. Additional SDKs can be downloaded using the update site.

 

After this is installed you can use the update site for the BlackBerry Web Plug-in for Eclipse 2.5 to install the Web Development tools to this Eclipse instance to keep only 1 Eclipse install for both development environments.


That means I have to reinstall and configure my entire dev. environment from scratch just to test the BB tooling for OS X ? I'm more than happy to test the BB plugin for OS X and give feedback, but not if it's going to take me the better part of the day just to get it installed. 

 

Why the assumption that I only use Eclipse for BB dev ? I also need the SDK's for Android, J2ME, Glassfish other than that I need plugins for source control, code review, integration with bugtracking system, SCRUM tools, unit testing/code coverage, etc.

If everyone operated like this I'd need 16 eclipse installs just to get all the tools I need.  Please provide a plugin-only install, the current option is basically useless. 

 

Developer
mreed
Posts: 1,041
Registered: ‎07-16-2008
My Device: ಠ_ಠ

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

[ Edited ]

When do you expect the update site to be Fixed? Avid Eclipse users don't like standalone packages like this. You are likely cutting off valuable testers by not supporting the update site upfront.

Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

We have brought this issue to the attention of Development and it is being looked into. No timeline yet for when a new version may be available that doesn't require a stand-alone install but the forum will likely be the first place to get notified.

 

For now, the options would be to either stick with Eclipse 3.5 and the 1.1.2 Plug-in or reconfigure using the Eclipse 3.6 instance included with the 1.3.0 Plug-in.

 

Garett
@garettBeuk
--
Goodbye everybody!
Developer
jtp5120
Posts: 298
Registered: ‎05-02-2010
My Device: Bold 9700

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

The BlackBerry menu isn't available in the Debug perspective, does any one know how to add it to the perspective?

 

I don't want to switch between perspectives to just run the clean simulator menu option.

--Todd

Windows 7 Enterprise 64-bit (6.1 Build 7600) | Java SE Runtime Environment (build 1.6.0_24-b07) | Eclipse Version: 3.6.2 [M20110210-1200] | BlackBerry Eclipse Plug-in: 1.3.0.201102031007-19 | Java Compiler level: 1.3 | Targeting devices running OS 5 | Simulators: JDE 5.0 packaged 9700, 9630, 9300
Developer
pfiffi78
Posts: 242
Registered: ‎01-29-2009
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

A work around is:

 

Download the full installer: runit (it's just an unzip in the end). Then install your version of Eclipse 3.6 (I prefer the JEE version) and then just copy everything with net.rim.* (folders and JARs) from the features and plugins folder of the installed Eclipse version into your own 3.6 Eclipse.

 

Then install all other component packs (4.5 to 5.0) via the update site.

 

Then you can delete the Eclipse version from the installer.

 

Job done.

 

 

Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

That's what I did.

 

Be sure to do it in the plugin folder and features folder.

 

If there is one thing I love it's the debugger speed (not attaching, but actual code stepping). Before it was like "Press a key, wait a second, press a key, wait a second, ..." etc. Now I press a key and it steps instantly, I thought I hit a wrong key by accident. It happened so quick compared to before.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.