If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
br14
Posts: 497
Registered: ‎06-24-2008
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

"one thing I love it's the debugger speed"

 

Tell me your secret, its even worse than the previous version for me. I'm running WIndows Vista 64 on a quad core processor with 6Gb and it took 30 seconds to step over one line of code, and thats the one time it worked. Lots of weird and wonderful "wait" conditions and "event lock" issues.

 

And anyone else have problems getting the simulator to run?  I've tried to test an app on OS6.0 with limited success. I can get it to run once, but the next time I try the simulator hangs.

 

Are there log files somewhere I could check?

 

The other issue I have is with installing the signing keys. I seem to recall I had to copy files around last time I updated, but I can't remember exactly what I did  :smileysad:

 

Back to the previous version I'm afraid. Along with the slow but steady debugger. 

 

The worst of it is I spent two hours today having to listen to a friend describe his joy at developing for Android. He claims his development workflow is considerably faster than with BlackBerry.

Please use plain text.
Developer
ekke
Posts: 1,439
Registered: ‎04-08-2010
My Device: Z10 (red Limited Edition), Q10, Z30
My Carrier: Telekom.de, O2, Vodafone

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

there are also some issues with 1.3.1 on OSX

http://supportforums.blackberry.com/t5/Java-Development/OSX-and-1-3-1-Eclipse-PlugIn/m-p/733913

 

so at the moment I couldn't do my work with SDK 5.0 + 1.3.1 on OSX

 

I like that 1.3.1 now is using Helios (Eclipse 3.6), better debugger-speed and new BB perspective.

 

But the development-cycle on OSX is very slow, because debugging is only available on the device and if you're developing complex Apps with some Libraries and you always have to sign the code before you can debug on the device this slows really down. or is there a hidden switch to avoid signing for debugging on device ?

 

ekke



-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
International Development Mobile Apps BlackBerry 10 Cascades
Cascades - Workshops / Trainings / Bootcamps

Open Source Enthusiast
blog: http://ekkes-corner.org videos: http://www.youtube.com/user/ekkescorner
bb10-development: http://appbus.org Twitter: @ekkescorner
Please use plain text.
Developer
simon_hain
Posts: 15,893
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

nope, no such switch, on a real device it has to be signed. I am trying the install, copy plugin, uninstall way now.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
simon_hain
Posts: 15,893
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

 


pfiffi78 wrote:

A work around is:

 

Download the full installer: runit (it's just an unzip in the end). Then install your version of Eclipse 3.6 (I prefer the JEE version) and then just copy everything with net.rim.* (folders and JARs) from the features and plugins folder of the installed Eclipse version into your own 3.6 Eclipse.

 

Then install all other component packs (4.5 to 5.0) via the update site.

 

Then you can delete the Eclipse version from the installer.

 

Job done.

 

 


 

I tried this but it did not work.

- installed helios (some time ago...)

- installed the full plugin installer

- copied all mentioned folders

-> still no blackberry options

 

it is working when i use the full installer version, but installing all the other plugins again?

in addition there is a strange error:

cvc-attribute.3: The value '4' of attribute 'Version' on element 'General' is not valid with respect to its type, 'VersionType'.    BlackBerry_App_Descriptor.xml

Am i not allowed to have a version number any more?

 

I hope the plugin will be available via the update site soon, until then i will stay with 3.5

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
simon_hain
Posts: 15,893
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

 


simon_hain wrote:

 

in addition there is a strange error:

cvc-attribute.3: The value '4' of attribute 'Version' on element 'General' is not valid with respect to its type, 'VersionType'.    BlackBerry_App_Descriptor.xml

Am i not allowed to have a version number any more?


 

ok, i am only allowed to use a version number in the format ab.cd.de (or a.b.c etc, up to two digits seperated by up to two points).

what is this, a joke?

if i want the version number 1.0.99: works. 1.0.100: doesn't work.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
pfiffi78
Posts: 242
Registered: ‎01-29-2009
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

 

I tried this but it did not work.
- installed helios (some time ago...)
- installed the full plugin installer
- copied all mentioned folders
-> still no blackberry options
 

 

Simon, you also need to copy the net.rim.* JAR files in the plugins folder and not just the folders.

 

Please use plain text.
Developer
jtp5120
Posts: 298
Registered: ‎05-02-2010
My Device: Bold 9700
My Carrier: Verizon

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

Is the update site applicable yet? I cannot afford to spend the day reconfiguring my dev environment.

<rant>RIM get your act together, I'm tired of my projects being looked at with disgust compared to Android or iOS.</rant>
--Todd

Windows 7 Enterprise 64-bit (6.1 Build 7600) | Java SE Runtime Environment (build 1.6.0_24-b07) | Eclipse Version: 3.6.2 [M20110210-1200] | BlackBerry Eclipse Plug-in: 1.3.0.201102031007-19 | Java Compiler level: 1.3 | Targeting devices running OS 5 | Simulators: JDE 5.0 packaged 9700, 9630, 9300
Please use plain text.
Developer
simon_hain
Posts: 15,893
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

copied them as well, but did not work. i used the "full install" helios now, but autocompletion is not working. no time to toy around, switched back to 3.5 again.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.2174, Z10 (STL100-3)-10.3.0.700 Dev OS, Z30 (STA100-5)-10.3.0.700 Dev OS, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

[ Edited ]

@simon: I can confirm the version issues. Your little test case works as you describe. It won't take more then 2 digits for a version number.

 

As for the copying of folders (maybe this is why my debugger is going quick as well):

  1. Install the full version of BB Eclipse (since it has been customized to a respect)
  2. Install the Eclipse Helios you want.
  3. Copy over the following files/folders ('X' being a generalized version of the name):
    1. In the "plugins" folder:
      1. The folder "net.rim.ejde.componentpackXXXXXXXXXX"
      2. The file "net.rim.ejde.doc_XXXXXXXXXXXXXXXX.jar"
      3. The file "net.rim.ejde.preprocessing.hook_XXXXXXXXXXXXXXXX.jar"
      4. The file "net.rim.ejde_XXXXXXXXXXX.jar"
    2. In the "features" folders:
      1. The folder "net.rim.EclipseJDE_XXXXXXXXXXXXXXXXXX"
      2. The fodler "net.rim.ejde.feature.componentpackXXXXXXXXXXXXXXX"
  4. Now for signing keys, create a folder "net.rim.ejde" in the "plugins" folder of Eclipse.
  5. Create a folder inside "net.rim.ejde" called "vmTools".
  6. Copy over the files (from the same directory structure as your old version of Eclipse and the newly created one):
    1. sigtool.csk
    2. sigtool.db
    3. sigtool.set
  7. The last step I did was change the "eclipse.ini" file. Find the following lines and change:
    1. "--launcher.XXMaxPermSize", there should be a line after that such as "256M", change it to "512M". There should actually be two of these lines.
    2. "-Dosgi.requiredJavaVersion=1.5", there should be two lines that start with "-Xmx" and "-Xmx". Change the "-Xmx" line to "-Xmx256m" and the "-Xmx" line to "-Xmx512m".
    3. I also happened to install the Flash Player Burrito so have the addition of two lines after the previous two lines of "-XX:MaxPermSize=256m" and "-XX:smileytongue:ermSize=64m"

Hopefully that helps.

 

P.S. Where the emoticon is should be ':' and 'P'

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
simon_hain
Posts: 15,893
Registered: ‎07-29-2008
My Device: Z10 LE
My Carrier: O2 Germany

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

 


rcmaniac25 wrote:
...

Hopefully that helps.

 


 

I doublechecked the presence of all files and folders mentioned.

still no luck on my manual helios install.

----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Please use plain text.