Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Administrator
MSohm
Posts: 14,516
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

BlackBerry Java SDK v7.1 – Now in Beta!

From the blog post here:  http://devblog.blackberry.com/

 

As a follow-up to the blog post Developer Roadmap: BlackBerry® BBX and the BlackBerry® Java® SDK, I’m pleased to announce that the BlackBerry Java SDK v7.1 is now in beta for both the BlackBerry® Java® Plug-in for Eclipse® and the BlackBerry® Java® Development Environment on Windows®, with Mac support expected to arrive soon.

 

The primary API features of this release are:

 

  • NFC Peer-to-Peer API, allowing applications to share files and other data through NFC technology initiated communication with Bluetooth® handover.
  • FM radio API, which is designed to give applications the ability to manipulate FM tuner settings on BlackBerry smartphones with supporting hardware.
  • Profiles API, which brings more Super App features to applications, allowing them to query current profile settings and adjust their own application behaviour accordingly; or, conversely, intelligently change the current profile to match the user’s current activities.

BlackBerry 7.1 OS will be available as an update for in-market devices running the BlackBerry® 7 OS, and will also be available on future BlackBerry smartphones that will be running v7.1.

 

This beta release of the BlackBerry Java SDK v7.1 includes a simulator for the BlackBerry® Bold™ 9900 smartphone running 7.1 OS, but developers leveraging net.rim.device.api.browser.field2.BrowserField are encouraged to also download an updated standalone version of the BlackBerry Bold 9900 simulator , which is designed to include a more stable environment for browser-based development.

 

To begin developing with these new features of the BlackBerry Java SDK v7.1 and to download the simulators for the BlackBerry Bold 9900 smartphone running OS 7.1, check out the BlackBerry 7 page on BlackBerry Developer Zone.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
smiley
Posts: 1,464
Registered: ‎07-14-2008
My Device: Z10
My Carrier: Fido

Re: BlackBerry Java SDK v7.1 – Now in Beta!

Thanks for the info Mark.

 

I'm getting an error msg saying that I already have a version installed and the Installer is telling me to remove the older version first. 

 

I have v7 installed.

Please use plain text.
Developer
Ebscer
Posts: 865
Registered: ‎08-31-2009
My Device: 9530, 9630, 9800, 8530, 9900, 9810, 9930, PlayBook, Dev Alpha
My Carrier: Verizon

Re: BlackBerry Java SDK v7.1 – Now in Beta!


smiley wrote:

Thanks for the info Mark.

 

I'm getting an error msg saying that I already have a version installed and the Installer is telling me to remove the older version first. 

 

I have v7 installed.


I am seeing the same error here...


Read my thoughts on BlackBerry Development at news.ebscer.com
Please use plain text.
Administrator
MSohm
Posts: 14,516
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: BlackBerry Java SDK v7.1 – Now in Beta!

That's a known issue (covered in the release notes).  You'll need to remove the 7.0 JDE or use the Eclipse plug-in.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
Ebscer
Posts: 865
Registered: ‎08-31-2009
My Device: 9530, 9630, 9800, 8530, 9900, 9810, 9930, PlayBook, Dev Alpha
My Carrier: Verizon

Re: BlackBerry Java SDK v7.1 – Now in Beta!

So much for using any of these features...


Read my thoughts on BlackBerry Development at news.ebscer.com
Please use plain text.
Developer
streak81
Posts: 204
Registered: ‎08-09-2010
My Device: 9930, PlayBook
My Carrier: Verizon Wireless

Re: BlackBerry Java SDK v7.1 – Now in Beta!

[ Edited ]

Hi Mark -

Can you provide a list of the devices that support the FM tuner?  Will current devices support this feature or is it reserved for future devices only?

 

Thanks!

 

 

Edit:
The reason I am asking is because when I use the sample code for initializing the FM tuner as posted in the 7.1 API and run it on the updated 9900 simulator, I catch the following exception:
"Device not supported"
 

Please use plain text.
Administrator
MSohm
Posts: 14,516
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: BlackBerry Java SDK v7.1 – Now in Beta!

[ Edited ]

Current in market devices do not support the FM tuner.  It will be supported in future, yet unannounced device releases.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Developer
streak81
Posts: 204
Registered: ‎08-09-2010
My Device: 9930, PlayBook
My Carrier: Verizon Wireless

Re: BlackBerry Java SDK v7.1 – Now in Beta!

Thank you for the clarification!

Please use plain text.
Developer
smiley
Posts: 1,464
Registered: ‎07-14-2008
My Device: Z10
My Carrier: Fido

Re: BlackBerry Java SDK v7.1 – Now in Beta!


MSohm wrote:

In market devices do not support the FM tuner.  It will be supported in future, yet unannounced device releases.


Mark, If understand you correctly you are saying RIM is going to release more new devices base on OS7.1?

Please use plain text.
Administrator
MSohm
Posts: 14,516
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: BlackBerry Java SDK v7.1 – Now in Beta!


smiley wrote:

MSohm wrote:

In market devices do not support the FM tuner.  It will be supported in future, yet unannounced device releases.


Mark, If understand you correctly you are saying RIM is going to release more new devices base on OS7.1?


Correct.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.