Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
mattgaunt
Posts: 21
Registered: ‎07-13-2009
My Device: Not Specified

Blackberry 9000 (Bold) Device and my app on 4.6.0 jde component pack

Hey everyone,

 

I've written an app using the eclipse 4.6.0 jde component pack and it compiles and runs fine on the simulator, I have now got hold of a device I want to test it on but I can't seem to get it on the device.

 

I'm trying to do it through the eclipse debug tool but it doesn't install into the downloads folder. My main concern is that the jde version might not match with the phone, which is running 4.6.0.126.

 

Now will it not work if they are slightly different or is it something else that could be going wrong? I'm having issues with everything in terms of getting this device to play nice with my computer as a whole anyway so not sure where to start.

Please use plain text.
Contributor
kbcmatt
Posts: 15
Registered: ‎07-05-2012
My Device: Bold 9000
My Carrier: N/A

Re: Blackberry 9000 (Bold) Device and my app on 4.6.0 jde component pack

I am having exactly the same problem now. Did you ever solve this?

My Bold 9000 device is v4.6.0.303 and I have the BlackBerry_Simulators_4.6.0.303_9000.exe simulator installed so I don't know what's going on.

Should my application appear in downloads? Or applications? Or just on the main menu?

Thanks.
Please use plain text.
Developer
peter_strange
Posts: 19,603
Registered: ‎07-14-2008
My Device: Not Specified

Re: Blackberry 9000 (Bold) Device and my app on 4.6.0 jde component pack

Downloads.

 

Make sure you are using the 4.5 Eclipse JRE. I don't think there is a 4.6 version.

 

Alternatively, I would upgrade your phone to OS 5.0. 

Please use plain text.
Contributor
kbcmatt
Posts: 15
Registered: ‎07-05-2012
My Device: Bold 9000
My Carrier: N/A

Re: Blackberry 9000 (Bold) Device and my app on 4.6.0 jde component pack

I have BlackBerry JRE 7.1.0.

Are these the OS version numbers? I'm pretty new to BlackBerry in general.
Please use plain text.
Developer
gluth
Posts: 192
Registered: ‎09-23-2009
My Device: 9860/PlayBook/Dev Alpha
My Carrier: Plus GSM

Re: Blackberry 9000 (Bold) Device and my app on 4.6.0 jde component pack

Compiling for old device require download of 4.6 jde component, and this is minimal OS version on which this app will run. Try with older SDK, available as update.

Found my post helpfull? Like it! It solves your trouble? Help others and accept it as solution. Search before asking.
My apps: Secret Cod3s | Should my tablet be banned?
--
Jakub Nietrzeba
PGS Software S.A.
Your reliable partner in Poland - IT Outsourcing - BlackBerry, iPhone, Web and Standalone applications
Please use plain text.